Audacity crashes with problem report opening or importing a file

I had this problem 2 and a half years ago and posted it here There I found a solution that helped temporarily but the problem was not solved finally and came back again. Also the link I mentioned in the solution description actually is broken, so I start a new trial to solve this problem:

I’ve been working with Audacity since a long time under Windows 7.
Now, after Change to Win 10, I can install Audacity and start it, but as far I try to open or import a file, Audacity ends and vanishes from my screen and brings a problem report similary to this:

Operating system: Windows NT
CPU: amd64
     family 23 model 8 stepping 2
     16 CPUs


Crash address: 0x70
Process uptime: 18 seconds

Thread 0 (crashed)
 0  Audacity.exe + 0x672167
    rax = 0x0000000000000000   rdx = 0x00007ffff23afe74
    rcx = 0x00007ffff23a0000   rbx = 0x0000004fc1f548e0
    rsi = 0x000000000000000d   rdi = 0x00000000000a0786
    rbp = 0x0000000000000019   rsp = 0x0000004fc1f54480
     r8 = 0x0000000000000000    r9 = 0x00000000000002a4
    r10 = 0x00007ffff24515f0   r11 = 0x0000000000000246
    r12 = 0x00000000000a0786   r13 = 0x00000000000a0786
    r14 = 0x000000000000000d   r15 = 0x0000000000000001
    rip = 0x00007ff7d6a72167
    Found by: given as instruction pointer in context

    Stack contents:
     0000004fc1f54480 e0 48 f5 c1 4f 00 00 00 0d 00 00 00 00 00 00 00  àHõÁO...........
     0000004fc1f54490 30 29 00 80 01 00 00 00                          0)......        
    Possible instruction pointers:

 1  HcDLL2_30_x64.dll + 0x2930
    rsp = 0x0000004fc1f54498   rip = 0x0000000180002930
    Found by: stack scanning

    Stack contents:
     0000004fc1f54498 08 45 f5 c1 4f 00 00 00 00 00 00 00 00 00 00 00  .EõÁO...........
     0000004fc1f544a8 00 00 00 00 00 00 00 00 01 00 00 00 00 00 00 00  ................
     0000004fc1f544b8 20 29 3b f2 ff 7f 00 00                           );òÿ...        
    Possible instruction pointers:

 2  user32.dll + 0x12920
    rsp = 0x0000004fc1f544c0   rip = 0x00007ffff23b2920
    Found by: stack scanning

    Stack contents:
     0000004fc1f544c0 01 00 00 00 00 00 00 00 18 46 f5 c1 4f 00 00 00  .........FõÁO...
     0000004fc1f544d0 00 00 00 00 00 00 00 00 ff ff ff ff ff ff ff ff  ........ÿÿÿÿÿÿÿÿ
     0000004fc1f544e0 ff ff ff ff ff ff ff ff 03 e7 3a f2 ff 7f 00 00  ÿÿÿÿÿÿÿÿ.ç:òÿ...
    Possible instruction pointers:

 3  user32.dll + 0xe703
    rsp = 0x0000004fc1f544f0   rip = 0x00007ffff23ae703
    Found by: stack scanning
(The entire file is too large to include it here)

I have this behavior with my computer with amd Ryzen 7 cpu as well as with a NUC with Intel i3 cpu.
A trial with an oder laptop with i5 and running under Windows 7 the first time I started vers. 3.2.1 also crashed this way but the system told me that it made something with the compatibility mode and after this here audacity starts an could import a wave file without problems. On a 4th computer (Dell Laptop) audacity ver. 3.2.1 (64bit) works.
I have this problem since I tried version 2.3.2. With the legacy 2.0.6 portable version I do not have any problem. I also read the machine requirements section and I think that both of my concerned Win 10 computers comply with the requirements.

Is anybody there who can help me with this problem…?

Possibly not. :cry:

Since your original link was broken, we are not sure exactly what the fix was the first time around. I might start with an internet search on “how to fix windows 10 file explorer keeps crashing”.

Is the file system in question located on an internet or cloud drive ?

Does this help?

@ steve: you had the same idea like me meanwhile, your link ist the saved copy of my broken link in the older thread at
I tried all these steps actually again but they do not help.
And actually also on my Dell Laptop where it worked (once) at first I have now the same problem.
Because I have this problem on severl computers I ask myself, why does nobody else has this problem.

@jademan: see above, and the files are locally on my devices.

The problem vanishes if I start Audacity (actually ver. 3.2.2) as Admin