Audacity crashes when using Macro Wizard

OS: Windows 10
Audacity version: 3.2.3 (Though issue has occurred for a while, long before updating to most current version)

(Note: Tried finding other people with this problem, but either nobody has it or more likely I failed to find it.)

Any time I try to use macro wizard on multiple files, the app crashes. It will complete one, sometimes two or even three, but then it will crash. When it does crash, it always crashes at “deleting undo/redo history”
Audacity crashes at.JPG
I then get the following error message
Audacity Exception Code.JPG
I’ve tried sending the report, but half the time the app fails to do so.

When I restart Audacity after a crash, it allows me to choose to discard/keep/etc the previous project.
I discard it and go on to start the process again. (After checking which files were successfully run through the macro before the crash)

I did try to see if resetting the configuration would help. It seemed to at first, but then the app crashed again on the third file.

(Note: I tried posting the text from the text box of the error message for sending, but it is LOOOONNNG and the system wouldn’t let me post a message that long.)

Do you care to post your macro? Hint: You can find your saved macros in: “%appdata%\audacity\macros”

Also, about how long are the files being processed? Are they .WAV files, MP3 files, M4a, etc. ?

OS: Windows 10 Pro freshly updated
Audacity 3.2.4

Very similar issue. Every time I try to use wizard with “MEB_Mastering” macro on “026_Chapitre_17_Une_visite,_et_le_jeûne_prend_fin.wav” file, the app crashes.


  1. It always crashes at the END after “Exporter en WAV”.
  2. Input wav file size seem to be a condition : crash over 75 MB (not strickly tested).
  3. Macro-output files are OK : MEB_Mastering macro did the job.
  4. No problem on Linux Audacity 3.2.4 / VGN-NS21Z Debian 10.13 with same MEB_Mastering macro on same wav file.
  5. I noticed that BugReport mention amd64 CPU instead Intel ?
  6. I’ve tried sending the report, but the app always fails to do.
    ComputerData.txt (675 Bytes)
    BugReport.txt (162 KB)
    MEB_Mastering.txt (726 Bytes)

So I am thinking that commas are not allowed in file names. Do you have the same problem without the comma ?

Yes Audacity crashed also without comma :
“026_Chapitre_17_Une_visite_et_le_jeûne_prend_fin.wav” (92,8 Mo)

File list has 55 items (audiobook chapters). I did select all and now Audacity crashed after :
“015_Chapitre_6_Ne_sois_pas_un_Judas.wav” (84,3 Mo) another big one.

What about content of the attached BugReport.txt ?

Does it crash when you select only that one file ?

Yes app crashed with only “015_Chapitre_6_Ne_sois_pas_un_Judas.wav” on empty macro-output folder.
But as told the project now in macro-output folder is fine, the macro did the job.
Problem is only that Audacity crashes :
Crash address: 0xd0
Process uptime: 53 seconds

Good. The important thing is that you are up and running. :smiley:

If you wish to supply sufficient information to reliably reproduce the problem, please open a bug issue here: Issues · audacity/audacity · GitHub. You may have to create a (free) login. :smiley:

I still see this problem on the current version of Audacity 3.4.2 in Feb 2024 on Windows 11. Macro runs fine on one file, crashes if running on multiple files, related to cleaning up its undo stack.

As a work-around, I can manually add a bunch of Undo’s at the end of the macro, which seems work.

Without that artificial Undo’s, it crashes. When it does, it produces this error, and salting the wound, hitting the “Send” button on the crash report, it says, “Failed to send crash report.” So the Audacity developers aren’t even getting the crash reports from this bug.