Audacity Crashes When Trying to Export

Hello, I’m running the latest version of Audacity and have been using it with no problems for the last few months or so. Then, out of the blue, one day I try to record something and go to export it and when I try to pick a different folder to export too Audacity crashes. The problem continued so I un-installed Audacity and deleted the Audacity folder in my Program Files and deleted the Audacity folder in “Appdata/Roaming”. I redownloaded it and now when I try to export anything it pulls up the window to pick the export location but then freezes right away.

Please help!

Does Audacity crash when you export to the folder that you used to export to?

Does the crash occur as soon as the Export File window opens, or only after you press Save?

What is the problem folder? Is it on an external drive that isn’t working properly?

Have you checked in Windows Explorer to see if you have write permission on that folder? You can right-click over it > Properties to find out.

If you ever had Audacity 1.2 on that computer then to ensure Audacity starts with factory fresh Preferences you should reinstall it, putting a check (tick) mark in “Reset Preferences” half way through the installation process.


Thanks for replying Gale.
The crash occurs as soon as the export file window opens. I get no chance to change format, change folder, or name the file.

There is no problem folder. It used to be that I could export things only to my most recently used folder and if I tried to change to a different folder it would crash. Now, after I re-installed it, it freezes as soon as I open the export window.

When I reinstalled, I did make sure to check that box but it didn’t seem to fix the problem.

Hope this helps some. :slight_smile:

What was your most recently used folder that you could export to - the exact path to it ?

If you have correctly reset Preferences then Audacity is probably trying to export to its installation folder. Where have you installed Audacity (exact path)?

Are you running as administrator? If not - log out and log in as an administrator. Alternatively if you need to run Audacity without privileges, exit Audacity then edit audacity.cfg - it’s in the AppDataRoamingAudacity folder. Look for an [Export] line. Add the [Export] line if it is not there.

Then under the Export line, add a fresh line pointing to your Desktop thus:


Replace “gale” with your own user name. Make sure you include the double slashes. Save the audacity.cfg file and try to export again.


The most recent folder I was able to export to was this one:

Audacity is installed at:
C:Program Files (x86)Audacity

And I double checked and I am running as administrator.

Also, as an update, I added that line of code to Audacity and now it let’s me export things to the ‘My Documents’ folder but if I try to switch to any other location that isn’t a folder within ‘My Documents’, it crashes. I normally save my things in the ‘My Music’ folder so it would be nice if I could get it to export to there but this code does at least make it functional and I can just move the file after it is exported into the documents folder.

Just because we’ve had problems with this, are you recycling filenames? Is each export a totally unique filename, or are you trying to save a new show on top of an old one?

No I haven’t been recycling file names, some cases I don’t even get to name the file at all.

The code I gave should have made Audacity open the export window at your Desktop, so something is broken if it opened somewhere else.

If you want to export to “My Music”, quitting Audacity and adjusting audacity.cfg thus should work:


From your description, it sounds to me like you either have broken Windows permissions, or perhaps you have installed some window management program that is interfering with Audacity. Can you open files from the problem folders, or change the open folder in Notepad?

If you open the problem folders in Explorer, do they have lock symbols? If you right-click over them > Properties, are they read-only?

In the pink header we ask for the full three-section version number of Audacity from Help > About Audacity - what do you see there? Many people who say they are running the “latest version” are not doing so. If you need it, the latest 2.0.3 is here: .


Hey Gale,
For some reason, even with the code, Audacity once again will not let me export anything. Although, I’m pretty sure this may not be Audacity’s fault as the same thing happens now when I try to save a project file in Sony Vegas. No other programs have trouble saving or opening files however.

I guess if it isn’t Audacity’s fault it may be out of your area of expertise so can you think of anything that could be wrong? I tried posting on the Windows 7 forums but still have gotten no reply from the people there.

I use both Sony Vegas and Audacity a lot since I run a YouTube channel and also enjoy making short films with my friends so if you have anything you think could help please tell me. You’ve been very helpful thus far.


As I said:

Did you open Help > About Audacity? What is is the three-section version number?


Sorry forgot to mention about that stuff.
Shouldn’t be any problems with permissions since my account is the only one on the computer and it is an administrator account. If that’s not right let me know.

I can definitely open the files that are in the ‘problem folders’ (Ala, every folder).

And yes, I can open the the folders in explorer and none have lock symbols or are read-only.


It’s not necessarily right. You can still have problems with “taking ownership” of files if Windows permissions are messed up.

So did you install any window-changing or interface-changing programs? For example are you on Windows 8 and trying to make it look or act like Windows 7?

Any reason you won’t give us the three-section version number of Audacity? If you have some modified version of Audacity then you need to get support from the person or company who modified it. We won’t help you because we have no idea what changes they made.


Whoops… felt like I was forgetting something… just checked and I am running Audacity version 2.0.3. I installed some plugins a while back but I’ve reinstalled everything now so those should be gone if they would’ve been causing a problem.

I don’t know if this fits under the category but I did install a program called WinColor or something like that which was supposed to allow me to change the color of the Windows 7 Basic theme from that ugly light blue color.

The program ended up not working so I deleted it and uninstalled it, you think there are still remnants of it?

Have you tried Windows Control Panel, search for System Restore then choose “Restore system files and settings from a restore point”? Choose the last restore point before this problem started.


I looked there but the earliest one was 8/7/13 which was after the problem started. I check “Show More Restore Points” but that didn’t seem to do anything. Anyway I could find earlier restore points?

Obviously not. You either aren’t allowing enough disk space for restore points or not creating enough manual restore points.

Perhaps you should go through your installed programs or review what changes were made just before the problem started.

Are you getting any input from the Windows Seven Forum? I don’t think this is an Audacity problem.


Yes someone did reply just last night and they are trying to help me with the problem. I really appreciate your help, so thanks and I probably will just keep troubleshooting with the guys over there.