Audacity could not find a place to store temporary files

I have a similar problem (Audacity 2.1.2 on Win 10). Audacity will no longer start and produces the following message: ‘Audacity could not find a place to store temporary files. Please enter an appropriate directory in the preferences dialog’. Of course, I can’t do this as Audacity won’t start. Since ver 2.1.3 is available, I tried to install it (without removing 2.1.2), but get the following message: 'Setup was unable to create the directory “C:\Users\XXXX\AppData\Local\Temp\is-FDSMC.tmp”. “Error 5: Access is denied”. Seems like the Temp directory is locked somehow. Tried to attach a file, but .docx & .pdf apparetly not allowed. What format is allowed?

I would suggest that you uninstall all versions of Audacity that are currently on your machine, then, while logged in with your normal user account, install Audacity using the recommended “EXE” installer (available here: During the installation process, look for the option to “Reset Preferences” and ensure that option is selected. On first run, confirm that you wish to reset preferences.

Solved this by using the 2.1.3 zip download. I just set up a temporary folder and unzipped all files to there. It ran perfectly. Then I was able to run the 2.1.3 .exe download, which worked this time and installed 2.1.3 to the original program folder. I’m now enjoying the new options on the Transport/Timer Record Menu. Great stuff!

Thanks for posting how you fixed the problem.
Note that when you next update Audacity you will need to manage this again because Audacity is not aware of your custom installation.