Audacity Consuming Hard Drive Space

Windows 10

Audacity 2.1.1/2.1.2

I use Audacity extensively on a daily basis, and generally produce audio recordings ranging between 1 and 3 hours in length. This issue that I’m having has occurred for the most part on what I would assume to be one version before the current one, but after updating to the current version, 2.1.2, this problem has not been rectified. When I record audio, or process my audio in Audacity using the noise removal function, Audacity consumes my hard drive space, and a lot of it. I am by no means exaggerating when I say that I have lost 100gb plus of space on my hard drive solely through recording and applying noise removal on audio files that have been recorded in Audacity. I do not know how it is eating up my space, but just before posting this I tested it out, and it consumed a bit over 1gb of space just by adding noise removal to a 1 hour and 42 minute- long audio file, and simply recording audio consumes even more than that. Just yesterday I freed up about 20gb of space on my hard drive, and have since recorded about 4 hours of audio. I am now down to 2.50gb of space on that hard drive. I will mention that these recordings do not exist in a project file when they are being recorded, or when they are having their noise removed. I export the files onto a separate hard drive, and I will mention that the exporting process does not consume hard drive space outside of the file that is being added to that specific drive (which is not the one that gets consumed by recording audio).

I have not been downloading anything on this machine, as I have been saving what little space I have to simply record and process my audio. I have been monitoring the consumption of my space so as to be definite that Audacity is behind it, and there is no doubt in my mind that it is the cause. If I do not touch Audacity, I lose no space, but I can start recording in Audacity and refresh my devices and drivers page and see the space slowly getting eaten up; and after a few hours of that, it really adds up. I have tried to search for possible files Audacity has created that has consumed so much space on my hard drive; I have checked not only in the Audacity folder in programs but also the Audacity folder in appdata, and these files are certainly not present in these locations. I have not yet tested if this happens with other recording software, but what I am most interested in learning at this point is how to retrieve all of this lost space, or how to locate these files that have filled up my hard drive.

Any and all help is greatly appreciated, as this is very stressful. Thank you very much.


“Using” a 100 GB when recording 3 hour sets, is not unusual, especially when using noise removal. Some of these files are temp files, though and should be deleted when the job is finished and you close Audacity.

Maybe Windows is preventing Audacity from deleting temp files?

Have you checked the path to temp files in Audacity’s preferences? It’s under “Directories”. Have a look in that folder and see if you can manually delete the temp files if any are present?

Also, whenever you take any action, Audacity makes UNDO copies. So some trimming and applying noise reduction, that’s similar to storing a 12 hour show.

People look longingly at tiny, efficient MP3 files, but you can’t do production in those without sound and timing damage.

recorded about 4 hours of audio.

What’s the show? I don’t know that I could keep up a four-hour monologue, even if I had a guest or two…or three. Are you recording Skype interviews?


As I outlined in my initial post, I have checked the appdata folders associated with Audacity and have found no such temporary files. As you recommended, I checked ‘Directories’ in the Audacity preferences, and when I looked in the folder it specified, I found it to be empty. No temporary files whatsoever were stored there. I find it hard to believe that it’s a typical function of this software to consume somewhere within the region of 5gb through recording one single hour of audio, before anything has even been exported. To further isolate the cause, I tested out Audacity on my other pc (also running Windows 10 and Audacity 2.1.2) and I could press record and see the same amount of space being slowly taken up in my (C:) drive.

Because I first suspected this to be some kind of temporary file storage issue coming from Audacity, I made sure to check appdata and there was nothing to be found above even 1gb in any of those folders; this much could be consumed in about 10 minutes of recording. There must be files that it’s storing somewhere, and it is not in the folder specified in ‘Directories’.

  • Edit: Sorry, I can’t edit my previous post, as it hasn’t yet been approved. I have located the temporary files; it was in the location C:\Users'User’\AppData\Local\Temp\audacity_temp. This was not the directory specified in ‘directories’, as it seems the update from 2.1.1 to 2.1.2 has changed the directory, and because I have only used this new updated version audacity for a short time, there were no files there. I had to check this directory on my other pc, which did have the previous version of Audacity on it, which then showed the correct temp file destination for me. The advice to check the directory in preferences has worked, and yes, it seems that for some reason Audacity has not deleted these temp files automatically (which I have read is something Audacity usually does). There are 261gb of temp files stored in here, and I can’t tell you how satisfying it is to delete them.

Thank you very much for your help.

  • Triskelion

By default Audacity takes 20 MB of space per minute of recording, so 1.2 GB for an hour of recording. If you edit the whole track three times, you are using 4.8 GB (because of the undo/redo storage).

If you leave Audacity running without doing File > Close, it will will continue to use space. Closing the track will not release space.


I have the exact same problem on MacOS.
And unfortunately when I try to change the temp directory folder, it doesn’t allow me, saying that “unavailable:the location doesn’t exist”.
So, what’s the solution?

If you have the “exact same problem” then you should update. Audacity 2.1.2 is ancient. The current version of Audacity is 3.0.2

I’m closing this topic because it is too old to be useful. If you still require help, please start a new topic on the forum that is relevant to your operating system.