Audacity clipping waveform even though I still have headroom

I don’t know why it’s doing this. I had to reinstall my OS and I reinstalled Audacity and when I’m monitoring, and recording, what’s in my iTunes, with the iTunes volume about 75%, audacity is hard clipping some of the wave form even though there’s still headroom. Also, the VU meter for left and right channels won’t go past about -8dB even though the song is obviously louder.

I can get the VU meter to increase in amplitude by increases the volume on iTunes however this doesn’t not solve the hard clipping problem.

It wasn’t doing this before I had to reinstall my OS.

I’m using Audacity 2.0.5 and Windows 7 64-bit
clipping zoomed out.jpg
clipping zoomed in.jpg
VU meter limit.jpg
Thanks for any help

Clipping will occur if any part of the signal chain is overloaded. For example, if you have:
microphone → mic pre-amp → USB analog to digital computer → Computer sound system → Audacity
If any part of that chain is overloaded, the audio will be clipped.
If the signal from the mic is too high for the mic pre-amp, the signal out from the pre-amp will be clipped and no matter how low you turn down the levels after the pre-amp, the signal will remain clipped.

To solve the problem you need to work out what the “signal chain” is, and “where” the clipping is occurring, the turn down the level at the appropriate place so that it does not clip.

How exactly are you doing that, and why are you doing that? If you already have a track in iTunes, why do you need to record it?

Yeah… I think we need to understand exactly what you are doing and what iTunes has to do with this…

My guess is that the file is already clipped before being loaded/recorded into Audacity. Plenty of commercial releases are clipped/limited, although usually at (or near 0dB).

Do you have [u]Sound Check[/u] enabled in iTunes? Sound Check will turn-down a clipped file if it’s “too loud”.

Okay, here’s my setup:

Windows 7 64-bit
Creative Sound Blaster Z internal PCI-Express Sound Card (with analog front, rear, (amplified) headphone, and center/sub out, and digital optical S/PDIF in and out)
iTunes 11.2.2.3
Audacity 2.0.5
(I also have an internal, dedicated ASUS HD 7770 video card, for which I have completely disabled the audio for, since it has HDMI-Out, by using Windows Management)

I have the digital optical out (S/PDIF), from the sound card, connected to a Fiio D3 (D03K) Digital-to-analog converter, which then is connection to my dedicated, external Schiit Magni Headphone amp

The (software) user-control interface for my sound card has several volume controls on it to include:

Playback:
-Speakers (for analog outputs)
-S/PDIF Out

Rec:
-Digital-In
-What U Hear

I have all of these levels set to 85%.
I have selected S/PDIF-Out as the default playback device using Windows.
The Main volume control for the entire interface also controls the S-PDIF Out level since it’s the default playback device

I have the iTunes volume, though Windows Volume Mixer, set to 80%, along with system sounds, and other programs.

If you’re wondering, I have all hardware & software (programs, interfaces, sound card, etc) levels set lower than 100% to intentionally lower the “gain” of all sounds from my computer, so I don’t accidentally blow my headphones or ears since my headphone amp is extremely powerful for my 50-ohm impedance Sennheiser HD 558’s

I’m monitoring what’s playing in my iTunes by setting the audio host in Audacity to “Windows WASAP”, and setting the input device to “SPDIF-Out (Sound Blaster Z) (loopback)”

Does recording clip if you choose analogue output and record from What U Hear?

You still have not answered the real question, which is why you are recording from iTunes. If you are recording a file, import it into Audacity instead. Or are you recording a radio stream?

Gale

I’d like to save that I have completely solved this problem on my own.

I reinstalled Audacity, and when I did, it asked me, during the install, if I wanted to include some type of hard limiter .dll or plugin or something along those lines. I don’t even remember it asking me last time to install any additional plugins right-off-the-bat but it did this time.

I tested it by playing a song that was being hard clipped before, and I see no hard clipping at all. All the peaks are there and no flat, horizontal lines whatsoever. I knew that it wasn’t my music, because it wasn’t doing this before I had to my reinstall for my OS.

Thank you all

I reinstalled Audacity, and when I did, it asked me, during the install, if I wanted to include some type of hard limiter .dll or plugin or something along those lines. I don’t even remember it asking me last time to install any additional plugins right-off-the-bat but it did this time.

I’m happy your problem went away. But, Audacity does NOT apply ANY effects while recording or opening a file, or automatically, or “accidently”. You have to select and apply effects manually from the Effects menu…

Hard Limiter and SC4 are plug-ins shipped with Audacity. They will install whether you enable them in that dialogue or not, and as Doug says, Audacity does not apply any type of effect while recording.

It is possible if you rebooted the computer it may have changed or updated some relevant driver.

If the problem comes back I suggest you uninstall the SoundBlaster drivers using Device Manager (if they are installed), then reinstall the SoundBlaster drivers from the Creative CD or web site.


Gale