Audacity can't find ffmpeg.55.64bit.dylib

Hello. I have Catalina 10.15.7, and have the new Audacity 3.0.2. I tried to open an .m4a file and was directed to download the ffmpeg library. I went through all the steps and used the installer for the 64-bit version, which claimed at the end that the library was installed. However, after restarting Audacity and going to Preferences, it cannot locate ffmpeg.55.64bit.dylib, and it doesn’t show up in the /libs folder either. I tried doing a search on my Mac and it cannot find the file anywhere, as if the package did not actually install anything. I have attached a txt file of the log. All it tells me is that the image is not found. Any ideas would be greatly appreciated. Thank you.
ffmpeg error.rtf (11.8 KB)

The place you want to look is /Library/Application Support/audacity/libs.

In the Finder, click on the Go menu and choose Go to Folder, then copy and paste the above underlined path into the Go to the folder dialog.

What do you see in that folder?

– Bill

Ok so that is definitely a different library folder than I was looking in before, but the only things that were in there were libmp3lame.dylib and libmp3lame64bit.dylib. The ffmpeg .PKG was not putting anything in that folder. I just tried the .ZIP file instead (despite the recommendation on the downloads page that the .PKG is better), and the ffmpeg files that I needed were in the .ZIP file. I have installed them and it is now working for me.

So thank you Bill for the path to install the files! I was able to drag and drop them over and then Audacity automatically detected them from there. I don’t know what is happening with the .PKG on my computer but it definitely wasn’t adding those files to that folder. Running a search in a Finder window for the entire Mac wasn’t revealing the files stashed away in a different directory either. It was like they just weren’t being installed at all. This is evidence in my case that the alternative download method is very helpful to have. Thanks again!

Glad you got it working.

– Bill


I have a similar problem, as the above referenced file is nowhere on my Mac. In the /Library/Application Support/audacity/libs folder, I have a long list of dylib files, but they all start with “lib”. For example, the first on the list is “libavcodec.55.dylib.” Is there a site from which I can simply download the FFmpeg.55.64bit.dylib file, then move it into the proper folder?

I am running Audacity 3.1.3 on a MacBook Pro running Mojave 10.14.6.

Thanks. Everett

Hello Rainshadow,

On this site you can try several downloads with the libs. I got an actual M1 with macOS 12.4 and the downloads worked pretty well for me.


1 Like

Here’s my recommendation for anyone having trouble with the FFmpeg. Trash your older version of Audacity and install the latest version. Open the new version up and go to Preferences/Libraries and go to the new download link. Depending on your version, the link takes you to a different page appropriate to your version. As of this post the newest version of Audacity is 3.3.3. It takes you to a universal binary FFmpeg file. Drag the requested file into the Library/Application Support/Audacity/libs folder. The file for 3.3.3 is “libavformat.dylib”. Follow the prompts in Audacity. It should install fine and require no relaunch of Audacity!

I finally manage to get this working! Thanks!