Audacity cannot see and audio device [SOLVED]

I cannot get audacity to see an audio device, even though there are 2 audio devices connected.
audacity problems.png

Windows has to be able to see devices before Audacity has access.

Audacity doesn’t support ASIO, so if it’s an ASIO device, Audacity will not connect to it.

Audacity checks for new devices when it starts. If you connect anything after Audacity starts it will be invisible. Restart Audacity or Transport > Rescan…


Have you deliberately disabled your built-in audio device and are only using external audio devices?

If not, then are you receiving “Internal PortAudio error” when you launch Audacity? If that happens, it is usually because you upgraded to Windows 10 from earlier Windows but did not update the drivers of your audio devices. See this link for how to update drivers and what to do if there are not any Windows 10 drivers for your devices:


Yep latest exe resolved issue thanks :smiley:

Can you tell us what you did? If it was something other than my suggestions, it might help other users.


Used the alpha release version.

Havent found any bugs in it.

I’ll mark the topic [SOLVED] and lock it then. Thanks.