Audacity cannot read file in /users/name/... anymore

Hi, there. I have a similar problem to a guy in the windows section of this forum; some user was kind enough to individually help him with his files, but I didn’t find a general solution, so I hope you don’t mind me posting my issue here.

My problem: After working many hours on an audacity project, incl. closing and opening it, suddenly I cannot open the project anymore. When I try to open the file, an error message is displayed (see below). First I thought this is a unigue problem, so I completely started the project from scratch, and now, many many hours later, the problem has occurred again, preventing my from accessing even the new file, which honestly brings me close to despair.

Have you seen this problem before and understand its origin? Is there a general fix for it? And specifically for my current project file, is there anyone able and kind enough to be able to restore it for me so it is accessable?

I’m using mac version 11.5.2 (Big Sur) and Audacity 3.1.2.

Here are the problem details:

(!) Audacity could not read a file in /Users/Erik/…

“timestamp”: 1638285817,
“event_id”: “5ba55fb5091648898b7e443f88803bd2”,
“platform”: “native”,
“release”: “audacity@3.1.2”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Macintosh”,
“version”: “10.16.0”
“exception”: {
“values”: [
“type”: “File_Error”,
“value”: “Audacity failed to read from a file in /MEINE .”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“sqlite3.rc”: “101”,
“sqlite3.context”: “SqliteSampleBlock::Load::step”

I would appreciate any help SO much!

Thanks a lot,

So, if you want, zip up your .aup3 file, and upload it to a file sharing service. Post (or PM me) a link; I’ll look at it.

Hi jademan,
thank you SO much, you are giving me hope! I am zipping/uploading the file right now and will send it to you in a few minutes. Again, thanks for taking the time to look into this!

Hi Jademan, I just tried to send you a private message, but it says “We are sorry, but you are not authorised to use this feature. You may have just registered here and may need to participate more in discussions to be able to use this feature.”. Is there any other way to do this…? If there isn’t, I’m also happy to post the Wetransfer-Link right here and delete it, after you downloaded the file…
Many thanks, Erik.

That will work; Possibly the moderator can PM it to me then kill the link in the post. You can probably make that request in your post.

BTW, most people are not interested in downloading projects that cannot be loaded anyway. :wink:

Hehe, that’s my guess as well :smiley:. So, here we go:

[…] This link leads to the main project file that I would kindly ask to to look at. It is my 2nd attempt at the project after the problem occurred with the 1st version of it…
[…] If the above files don’t work, this is the link to the original (now slightly outdated) version of the project.

Risking boring you withe repetition, thank you SO much!

Got it. Give me a while, please. :smiley:

Which show is this? There are two in the post.

You may be the bringer of good news although it may not seem like it to you. In order to solve programming problems like this, the developers need a way to reproduce the problem at will. You seem to be able to do that.

This is the phrase that pays.

“sqlite3.rc”: “101”,

This is when sqlite loses its mind and scrambles the organization of the show and its components.

Given we don’t already know what’s causing these crashes, it might be good for a developer to have a nice chat with you about your show and your editing technique.


Hi Koz,
I’m not sure what you mean with “Which show is this”? The show itself is a German podcast, but that has nothing do to with the 2 links in my post – as explained there, I included two links because I provided two different versions of the project file (one older, one newer, both broken). Or do I misunderstand you?

And, sure, if I can help your developers in anyway to get to the bottom of this, just let me know – I’m more than happy to repay the kind help in this forum!

koz, you may be thinking of error code “11” = corrupt. This is a different error - see:

Well, this is quite curious. When I deleted your WAL file, the project loaded without errors. Since you already have your project backed up as a zip file (and on we transfer), try giving that a go.

Let me know. :smiley:

Wow, that is curious indeed! - It works!

It is especially curious because the first (meaning older file) does NOT have a separate wal-file, but still doesn’t work (therefore I didn’t even consider just deleting thew WAL-file), so that seems to be one possible origin for the error, but not necessarily the only one…?

Either way, for now it seems to work with the newer file, which is awesome! Thank you so much! Please let me know if I can in any way make up for it. Best, Erik.

that you all are sorted. :smiley:

I’m glad

Don’t worry, I’ll send you a bill… via PM. :wink:

Hi there,

I have the exact same problem. Any chance I could upload my file too please? A lot of time was spent on this…so I’m super upset I can’t open it.

Even though I saved the project and closed Audacity, a separate WAL file’s appeared. Does this have something to do with the problem??


Thanks, Hat

So if you care to zip up your .aup3 project and upload it to a public file sharing service then post (or PM me) a link, I’ll take a look at it.

Ah it says I’m not authorised to send you a PM. How else can I send you the link privately? Thanks!

Sorry, forget my last message – here’s the link
But please can the moderator delete this message once the link’s been received?

Thanks for the link to the listing of error codes.


You are welcome. :smiley:

Ouch. In my initial tests, it doesn’t look as though we are going to be able to recover anything useful. :frowning: It would be good to start looking for alternative solutions. Right now, I have to run out for several errands. I’ll be back much later at which time I’ll take a second look.

I’m back; sorry for the delay.

Unfortunately, not all “exact same” problems are created equal. In this case, you are, in fact, getting the dreaded, “sqlite3.rc”: “11” = corrupt project errors to which koz was referring to earlier in this thread. :frowning:

 "type": "Error_Opening_Project",
                "value": "Failed to open database file:\n\n<path>Archive (<path>MAP <path>",
                "mechanism": {
                    "type": "runtime_error",
                    "handled": false,
                    "data": {
                        "sqlite3.rc": "11",
                        "sqlite3.context": "DBConnection::ModeConfig",

And in your particular case, I currently have no tools that can help recover your project. :frowning:

I was able to “extract” the audio information from your project, bypassing all of the database structures. I have PM’d a link to this “extracted” project.

You may or may not find this extracted data useful.