Audacity cannot open Dolby Digital audio file.

Hi, everyone!
Sorry for disturbance.
I am using Ubuntu 14.04 Audacity 2.05 with ffmpeg.
I tried to use Audacity to open Dolby Digital audio files extracted from Sony camera hd videos and failed.
For some reason after period of time it doesn’t work anymore although worked before.
Thank you for your attention.

Is this the packaged version of Audacity from the Ubuntu Software Centre? Have you updated Ubuntu and the problem started after that?

What exactly happens? If there is an error message, what does it say?

Do these files have AC3 extension? Do files you have imported in the past still import correctly?


Well, it’s 2.0.5+svn20141030+r8661+28~ubuntu14.10.1 installed from daily ppa of audacity team.
I misprinted the version of Ubuntu. It’s 14.10 actually.
VLC opens the file without problem. Audacity opened such files before successfully before with or without extension ac3.
In the properties of the file is written Dolby Digital audio.
It’s written “Audacity did not recognize the type of the file …”
01:29:30: Mime type is *
01:29:30: Opening with libsndfile
01:29:30: Opening with liboggvorbis
01:29:30: Opening with libflac
01:29:30: Opening with lof
01:29:30: Opening with libav
01:29:30: Error: FFmpeg : av_open_input_file() failed for file “Sound”.
01:29:30: Error: Importer::Import: Opening failed.

If I add ac3 extension audacity says: “It’s a Dolby Digital audio. Audacity cannot currently open this type of file. You need to convert it to WAV …”
01:32:51: File name is /home/rootkit/Desktop/poi.ac3
01:32:51: Mime type is *
01:32:51: Opening with libav
01:32:51: Error: FFmpeg : av_open_input_file() failed for file Sound.ac3
01:32:51: Opening with libsndfile
01:32:51: Opening with liboggvorbis
01:32:51: Opening with libflac
01:32:51: Opening with lof
01:32:51: Error: Importer::Import: Opening failed.

I tried to use version of Audacity from Ubuntu software center but it didn’t help.
Thank you for your attention.

Please be aware that PPA builds are not official Audacity releases. There may be bugs.

If VLC opens the file I suggest transcoding it to WAV with that application.

If you want to make a bug report (which may be a bug against FFmpeg and not Audacity), please provide an example file and give the version of FFmpeg that Audacity was compiled against.

The easiest way to find the FFmpeg version is probably to export something, choose “(external program)”, click “Options…” change to the built-in ffmpeg command, enable the “Show output” box, then type anything for the filename and click OK. You should see the FFmpeg version in the error report.


I am using ffmpeg 2.4.2 version. I found that audacity doesn’t like of that ffmpeg version. I managed to tell audacity to use ffmpeg 2.2.2 from blender package.
Providing sample ac3 file is a bit tricky as audacity is the only editor working under Linux I know that is capable cutting ac3 sound files.

I managed to open the file with alpha 2.0.7 of audacity.
Perhaps I used not good build of audacity after upgrade of Ubuntu.
Thank you for your attention

That does not surprise me. Audacity 2.0.6 was fixed to support up to FFmpeg 2.2.x. Any later FFmpeg version could break support again.

Hmm, I would have thought mencoder would open and trim an AC3 (and SoX too, relying on FFmpeg).


I tried sox. The build I used wasn’t able to work with ac3 files.
Due to API changes in ffmpeg/libav, the ffmpeg format handler will soon stop to compile (unless it is adapted to the new API, of course). Mailing list discussion has shown that there is no interest in keeping the handler; users should instead use the ffmpeg/avconf command line utility via pipes