Audacity cannot load Standard Theme


I’ve been using Audacity (2.1.0) for a while without any problems on Slackware 14.1. But suddenly the following messages appears when starting:

Audacity is unable to load its Standard Theme, please report this to the developers. (I hope the translation of the german error message is correct)

After confirming the message Audacity starts but all buttons are only black squares. Only thing I’ve changed in the system is removing two orphaned files of libtiff3.
libtiff5 is installed. I already tried to recompile Audacity and wxWidgets und installed libtiff3 again but it didn’t help.

Any ideas are appreciated.



The current Audacity source code tarball is 2.1.2 and HEAD is 2.1.3-alpha:

Have you reported the issue to Slackware? It sounds like a system update might have changed libraries. Slackware are the people to ask about that.

Does mousing over the buttons or resizing the window restore the buttons? Note that you may run into that behaviour if Audacity is built --with-gtk=3. Audacity should be compiled with the default gtk2 option.


I haven’t reported to Slackware yet because I’m quite sure that it’s not an update issue. I haven’t done any updates between the last time Audacity worked and now. I’ve been using Audacity quite often during the last weeks so I’m quite sure that I didn’t do any updates in between. Nevertheless there is the libtiff3 thing. I’m checking that. Audacity was compiled with the default gtk2.