Audacity can not load ANY aup file


I was working today with Audacity today, when it suddenly crashed. I was not phased much about this, as I just saved my project. So, I double click on my aup file, it tells me it wants to restore my project, I say yes, then it says it found orphan files, and I select continue without deleting and press OK, but what I got is just a big empty nothing. I tried everything: close it again, open again, I even restarted the computer, made a new project, when I save and close it, I can’t open! I used Audacity last Friday, and I didn’t have this problem. There was no version change in the meantime.
I am frustrated to no end. Please guide me on what steps should I take to troubleshoot this issue.

I use Arch Linux, installed it from the community repository with pacman.

Here’s the log:

00:18:04: Audacity 2.3.3
00:18:04: Warning: Cannot set locale to language "English".
00:18:04: Error: locale 'en_GB' cannot be set.
00:18:09: Trying to load FFmpeg libraries...
00:18:09: Trying to load FFmpeg libraries from system paths. File name is ''.
00:18:09: Checking for monolithic avformat from ''.
00:18:09: avformat not monolithic
00:18:09: Loading avutil from '/usr/lib/'.
00:18:09: Loading avcodec from '/usr/lib/'.
00:18:09: Loading avformat from ''.
00:18:09: Actual avutil path /usr/lib/
00:18:09: Actual avcodec path /usr/lib/
00:18:09: Actual avformat path /usr/lib/
00:18:09: Importing symbols...
00:18:09: All symbols loaded successfully. Initializing the library.
00:18:09: Retrieving FFmpeg library version numbers:
00:18:09:    AVCodec version 0x3a3664 - 58.54.100 (built against 0x3a3664 - 58.54.100)
00:18:09:    AVFormat version 0x3a1d64 - 58.29.100 (built against 0x3a1d64 - 58.29.100)
00:18:09:    AVUtil version 0x381f64 - 56.31.100 (built against 0x381f64 - 56.31.100)
00:18:09: FFmpeg libraries loaded successfully.
00:18:09: Warning: Orphan block file: '/home/nicemicro/Documents/test_data/eff/d1f/'
00:18:09: Warning: Orphan block file: '/home/nicemicro/Documents/test_data/eff/d1f/'
00:26:49: Warning: Project check found file inconsistencies inspecting the loaded project data.

That’s the first thing that strikes me as very peculiar. Is your computer set up for a non-English locale?

This is my output of the locale command:


I think I have the US, Hungarian and Korean locales generated. So, yeah, the en_GB local is not there, but why on earth Audacity wants that? Can that be related to the load issue? The program starts, I can import a wavefile, edit it and export it without no problem, I just can’t load saved projects.

That project is probably gone and lost forever.

To try and get back to a stable state, open Audacity, if it offers to restore an old project, select “No” so that Audacity is able to clear the junk out of the way. Then close Audacity and re-open. Audacity should now open without error. Do NOT try opening any other projects yet.

If Audacity now opens and closes correctly, create a short test project, and save it either to your Desktop or your Documents folder. Close down Audacity properly, then restart and see if you can open the project that you have just saved.

What happens?

I have done the following:

  1. Open Audacity
  2. It opens, no problem.
  3. I close Audacity, no problem.
  4. I run Audacity again.
  5. Record a short noise.
  6. Save project to Documents.
  7. Close Audacity.
  8. Open my file browser, double click on the .aup file
  9. Audacity comes up, it tells me about the orphaned files, get the same log entries as previously.
  10. The project is empty.

I have attached the aup file and the folder.
test.7z (792 KB)

What happens if you do this:

  1. Open Audacity
  2. Close Audacity
    (Ensure that it opens and closes with no errors or warnings)
  3. Launch Audacity.
  4. Record a short noise.
  5. Save project to Documents.
  6. Close Audacity.
  7. Launch Audacity.
  8. File menu > Open → select the saved .aup file and click OK.

Same result, project doesn’t load.

Does it list these orphan block files each time, or are they different files each time?


If I open the same AUP file, yes. In the second test I made, it is

12:14:29: Warning: Orphan block file: '/home/nicemicro/Documents/test2_data/eff/d1f/'
12:14:29: Warning: Orphan block file: '/home/nicemicro/Documents/test2_data/eff/d1f/'

This is very strange, because the test project that you posted is perfectly OK. It looks OK and I can open it without any problem.

I’m not sure what the file paths will be on Arch, so you will need to check these:

Look in ~/.audacity-data/. Do you see the files:


and the folder:


Assuming that you do, in ~/.audacity-data/ do you see a file named similar to:

New Project - 2020-03-06 10-13-43 N-1.autosave

Do you also have a folder:


If you do, does it contain one or more folders named something like:


The contents of that folder:

drwxr-xr-x  5 nicemicro nicemicro  4096 márc   6 22.48 .
drwx------ 37 nicemicro nicemicro  4096 márc   6 19.48 ..
-rw-r--r--  1 nicemicro nicemicro  2612 márc   6 22.48 audacity.cfg
drwxr-xr-x  2 nicemicro nicemicro  4096 márc   4 10.17 AutoSave
drwxr-xr-x  2 nicemicro nicemicro  4096 márc   3 00.34 Macros
-rw-r--r--  1 nicemicro nicemicro 36136 márc   6 22.48 pluginregistry.cfg
drwxr-xr-x  2 nicemicro nicemicro  4096 márc   3 00.34 Plug-Ins
-rw-r--r--  1 nicemicro nicemicro   642 márc   3 00.54 pluginsettings.cfg

The subdirectories (all three) are empty. There is no autosave file.

This directory exists, and contains no file or directories.

I have just installed Audacity 2.4.0-alpha-Mar 6 2020 from the AUR. The same problem still persists. So, I went back to the Audacity version in the repository.

The three “.cfg” files are Audacity’s configuration files. Deleting these three files (while Audacity is closed) will reset Audacity to it’s factory settings.
From ~/.audacity-data/ move these three files to your Desktop (or any other convenient location):


On restarting Audacity, you should see the welcome message.
Then try saving and opening a project.

If that works, please post those three files with your reply so that we can try to figure out how this happened.

I moved the three files somewhere else.
I opened Audacity, recorded a new project, saved it.
When I try to open it, I get the same error as before.


Can you Import audio files into Audacity?
what happens if you use the “File > Open” command and select a wav file?

Importing audio from video files (which is what I do most often) works, opening MP3s and other audiofiles also work. I can manipulate the audio and then export it to ogg files and that works well, too.

What are the permisions for the directory: /home/nicemicro/Documents
Are you logged in as “nicemicro”?

drwxr-xr-x  10 nicemicro nicemicro  4096 márc   9 22.36 Documents

Yes, my username is “nicemicro”. Could this be a permissions issue?

A bit of a long shot, but I’m running out of ideas of what the problem could be. User nicemicro has read write permissions to the Documents folder (as expected), so it’s not looking like a permissions problem.

In the project that you posted, the data files (.au) are present in the test_data folder, and their names match the names in the project file “test.aup”. Audacity should therefore recognise the data files as belonging to the “test.aup” project. When I try to open test.aup, Audacity does recognise the data files as belonging to the project (as expected). I can’t account for the fact that on your machine, Audacity does not recognise the .au files as belonging to the project.

When you get the warnings:

00:18:09: Warning: Orphan block file: '/home/nicemicro/Documents/test_data/eff/d1f/'
00:18:09: Warning: Orphan block file: '/home/nicemicro/Documents/test_data/eff/d1f/'

Do those files match the file names in the “test.aup” file? (View the “test.aup” file in a text editor).

Yeah, I have checked multiple test files, and the filenames align with what’s in the

simpleblockfile filename=""

parts. I found that the XML file contains a comma instead of the period sign as a decimal separator (my locale is a little weird as I use US English as the language but use Hungarian date and number formatting). I manually changed the commas to periods but didn’t have any effect.
Audacity used to work for me up until around 26th of February.
Now looking up the logs, the last change in Audacity was on 14th of february,

[2020-02-14T22:44:02+0900] [ALPM] upgraded audacity (1:2.3.3-1 -> 1:2.3.3-2)

which is a re-compiled form of the same version based on newer dependencies, I guess. But again, Audacity still worked after that. Is there a debugging mode that could be of help?