Audacity + Blue Yeti -> Weird Click Sound. Your Opinion?

Hello, when recording voice-overs in Audacity 2.1.0 with Blue Yeti mic, i get strange click sounds – a little like a tiny drop into water,about every 20 seconds (though not regularly); not very obtrusive, but noticeable to attentive listeners. The sound is not external, it is “digitally generated”. It can be removed, but that’s tedious. Otherwise, my recordings are fine – good full sound, no background noise, no hiss, very well usable.

Do you have any advice about those click sounds?

Equipment used:

Microphone Blue Yeti, cardoid (not Blue Yeti Pro), direct to USB port (no hub), with the default long cable

Laptops running on battery with Win 7, Win 8, Win 10 – the problem comes with every operating system, even though i think it’s worse on Win 8 and 10. Current laptop is new and strong.

Recording with Audacity 2.1.0 and these settings (:

  • Audio Host: Windows Direct Sound
  • Recording Device: Blue Yeti (not Primary Sound Driver or laptop mike)
  • Project rate: 48.000 (said to fit Blue Yeti)
  • highest volume ca. -3 dB
  • saved and edited as FLAC (clicks also audible in Audacity project files)

I was advised to install ASIO4All, but i can’t seem to approach it from Audacity (it IS visible from other applications on the same machine). Also it seems ASIO4All is about latency and that’s not at all my problem.

Do you know which settings could remove the weird click sounds?

As i’m here anyway: should i regulate microphone sensitivity with the Gain knob on the microphone or with the Recording Volume slider in Audacity?


Audacity doesn’t understand ASIO, so that’s not going to work. You’re right. That’s for latency and delays more than missing data.

Stuttering or missing chunks can mean the machine is not keeping up with the performance or there is processing interference.

Some virus protection programs have been known to interfere with Audacity trying to write new work to the drive. Take the machine off-line, disable the virus software and try recording again.

You noticed that as you went to busier and busier operating systems, the problem got worse. That points to a computer either too busy doing other things, or just flat underpowered.

Live audio (and video) stresses a computer. They can’t hold up their hands and say “wait a second while I finish processing.” It doesn’t work like that. Real time is real time and the computer has to be on top of it.

You can get increasingly serious speed problems if you’re slowly filling up your hard drive. What’s the size and how much room do you have left?


The volume controls in Audacity or Windows affect the overall volume of the work, so they’re a convenience more than anything else. The one on the microphone could affect the loudness of your voice as compared with the natural microphone noise. That’s very different and I would adjust it there. You can probably leave the Windows/Audacity one all the way up. I believe that’s its neutral setting.

If that proves unworkable, by the way, then you may be suffering from a Windows boost setting which probably shouldn’t be there.

The goal is blue waves half-way up (50%) and many peaks at -6 on the sound meters.

Unless you have specific reasons for not doing it that way.


50% and -6dB are the same number.


Koz, thanks for great and detailed explanations and links! I will certainly try them next time.

Since you asked - the new laptop with Win 8 and now Win 10 which creates more of the ominous click sounds has 500 GB of free hard disk. The voice-over tracks i record are never longer than 20 minutes.

The old Win 7 laptop which in my memory created less click sounds had much less available disc space.

Thanks again!

much less available disc space.

Disk space is only an issue when the space declines to the point that the operating system starts to panic. On the video forums we learn to recognize the phrase: “I’ve been doing this for months and suddenly, for no reason, the computer is acting funny and putting skips in the work.”

It’s still a speed issue. Restart the computer and don’t let any applications start by themselves. Audacity only. If you leave Skype running in the background “just in case,” shut it completely down. Disconnect the network before you restart. Make the computer start “knowing” the network isn’t there.

You can take this problem upside down, too. Break it. See what you can do to make it worse. Run a bunch of programs and minimize them without closing them. Does the noise get much worse?


Try disabling any Windows features you don’t need. That will spare you having to stop them loading on start-up.

I must correct that. Windows 8 and Windows 10 are much lighter operating systems than Windows Vista and 7, assuming no other problems. They should be using much lower CPU than Windows 7. On my main laptop with Firefox, Chrome and Audacity running, Windows 10 uses about 5% CPU versus 20% on Windows 7.


@ henrik2000, can you please post a sample of the click sounds? Please see here for how to attach files:


If you use a shorter cable or mains power, does it make any difference?

Is the cable leading directly away from the computer, not alongside?

If you are using that host it is probably best to make sure both “Exclusive Mode” boxes for Yeti recording in Windows Sound are enabled - but I’m not saying that is necessarily anything to do with the clicking.

If you experiment with MME host, make sure Default Format for Yeti recording in Windows Sound is also at 48000 Hz.


Hi all,

thanks for some detailed info and for support.

So far i already used the laptop with few applications running, if only to not distract me (e-mail was off, Skype of course too). Word 2003 is ON to read the text, but perhaps i should use another application to read RTF files?

Gale, i try to attach 8 seconds of completely uncorrected FLAC to this post. That example has several high click sounds right at the start and one more towards the end. It’s the most obvious extract that i found in about 10 minutes of recent recordings. It is not so obvious perhaps, but it’s annoying.

Gale, so far i didn’t try with shorter USB cable or with mains power. I could do so soon. The USB cable for the Yeti mike is very long. It hangs down from about 1,50 meters to the floor (i speak standing) and comes up again, so first and second half of cable run maybe 15 cms apart from each other. Mike and laptop stand quite close to each other (i need to speak into mike at close distance and read the text off the laptop)

I have set Default Format in Audacity to 48.000 Hz (having read it was good for Blue Yeti mike).

Gale, to be honest, your suggestion made me aware of the microphone settings in Windows Sound for the first time at all. Sorry. I found that so far the settings for the Blue Yeti have been:

  • 2 Channel 16 Bit 44100 Hz CD Quality (while i had switched Audacity to 48k Bit)
  • Applications have exclusive control over device (is activated)
  • Appications in exclusive mode have priority (is activated)

Should i change to “2 Channel 16 Bit 48000 Hz DVD Quality”? There are only these two options offered, and there is no mono option.

For my voice over i wish to record mono only, but sometimes Audacity creates more tracks. The FLAC export always seems to be mono though. There seemed to be no problem resulting out of this so far.

Thanks for your help!

What CPU use do you see when recording? CTRL + SHIFT + ESC to open Task Manager - on Windows 10, click “More details” in Task Manager if necessary.

I don’t see any clear indications of dropouts in your sample, but there are obvious spikes in the waveform which cause clicks and many quite abrupt direction changes where a few samples decrease significantly in amplitude where the trend is upwards (and vice versa). These direction changes “could” cause quiet clicks.

Mains power “might” introduce hum, but we should rule out the battery as something to do with the clicking.

That closeness is something you should investigate.

Yeti and Yeti Studio work at 48000 Hz, Yeti Pro works at 19200 Hz ( ).

Change Windows Sound Default Format to “2 Channel 16 Bit 48000 Hz DVD Quality”, to be on the safe side in case you try other hosts than Windows DirectSound. DirectSound should be the best host for Yeti in principle, but it is not so compatible as MME.

If you use DirectSound host with both “Exclusive Mode” boxes enabled, the Default Format in Windows Sound should not matter. Even with Default Mode set to 44100 Hz, you should see “Actual Rate” bottom right of Audacity show 48000 Hz when Audacity records at a project rate of 48000 Hz.

If you choose MME host, then Default Format should be changed to 48000 Hz if Audacity Project Rate is 48000 Hz, to avoid resampling between Windows and Audacity. Note that MME is always maximum 44100 Hz, so Windows will still convert from Yeti down to 44100 Hz, then back to 48000 Hz if Default Format is 48000 Hz.

Have you also tried Windows WASAPI host? That host is the newest one (WASAPI came in with Windows Vista). WASAPI “should” behave like DirectSound in that Default Format sample rate should be ignored if both Exclusive Mode boxes are enabled, but that is not always true.

None of this may be relevant to the clicking, but you have to look at all possibilities.

Hold SHIFT when you click Record, then Audacity will record at the end of the selected track.


And do keep an eye out for the ability to make it worse. If you decide to read from the laptop a little closer and the noise gets worse, we pretty much nailed it right there.

Do you keep your phone with you? I’ve had my phone ruin recordings.


Yes. Or if you are in an apartment, even the neighbour’s phone if you are close to a wall.

Or even a nearby cellphone mast.


Gale and Kozikowski, thanks for new detailed hints!

I have no problems with drop-outs. I only worry about the click-sounds.

Yes, i will try the recommended Windows settings. I will also try using mains and moving laptop and microphone further away from each other (which is a bit difficult; maybe if i print the text it is easier to separate them, but then, handling paper is another source of noise, even if i try to handle it only during breaks). I will def. put the laptop in flight mode and turn off antivirus after that. Laptop’s Bluetooth had always been off in previous recordings. I will also check CPU usage.

I do not have any phone with me and there is no phone shop nearby. The next cellphone mast is about 1500 mtrs away. The neighbour is at least 6 mtrs and a few fat walls away from the recording room. My home has DECT phones (wireless handsets to landline), but no handset in the recording room (the wireless DECT network is on, but the handsets in the other rooms are supposed to be in some low-radiance “health” mode). My 3G mobile is off anyway.

Thanks again!

moving laptop and microphone further away from each other

You don’t have to do that forever. Just for the 30 seconds it will take to find out if that helps. You can actually read the side of the milk carton. Text is not important.


Hello, now i have tried most of the tips from you and from the manual in my newest voice-over recording session with the Blue Yeti USB microphone, but the click sounds (with Win 10) remain unchanged (perhaps slightly less frequent, but perhaps just as frequent, certainly with same volume and characteristics). I attach a few of the most obvious samples.

Things i changed or had anyway activated (but obviously with little effect):

  • software playthrough off
    audio buffer set from 100 to 300 (don’t need “live audio”) (value high enough?)
    using 16 bit sample in Quality Preferences
    mono recording
    500 GB disk space available
    laptop in flight mode, antivirus off
    Audacity set to high priority
    checked CPU activity in task manager, was very low (very few applications active, but unfortunately Win 10 and also unremovable Acer bloatware might be rummaging (Win 10 is set to as inobtrusive as possible, no Cortana etc.))
    arranged microphone USB cable so that it is one long line, not two parallel lines
    plugged microphone USB cable into one side of the laptop and mouse and speakers into the other side (no hubs anywhere)
    changed Windows Sound Default Format to “2 Channel 16 Bit 48000 Hz DVD Quality” (48k was displayed everywhere in Audacity)
    used Windows Direct Driver. Wasapi didn’t work

Thing i didn’t change:

  • minimize the Audacity window (feel unsecure when i don’t see the “action” in the Audacity window)
    move laptop further away from microphone (very difficult practically)

Apart from the click sounds, i get very nice results – very clear voice, no hiss, solid silence in breaks. Incidentally, i had the chance to try recording with Adobe Audition on the same computer in the same room, but the sound was tinny and i got hiss (maybe did something wrong).

Perhaps i have to live with the clicks and learn better how to remove them in post? But i will still have to try recording with a different laptop.

You could try WASAPI again. It’s low latency which just possibly may help. If you changed Windows settings without restarting Audacity, WASAPI would probably error.

If WASAPI still errors after restarting Audacity, try changing the state of the “Exclusive Mode” boxes for Yeti on both the Playback and Recording tab of Windows Sound (that is, if they are enabled, disable them, or vice-versa). Then restart Audacity again.

It doesn’t sound as if the Acer “bloatware” should be an issue if Windows 10 is running on very low CPU, but you could consider backing up your data and doing a clean install of Windows 10 from the Microsoft media creation tools at (or from a DVD if you already have one). This would get rid of Acer applications and could even help the clicks. Reinstalling Windows can sometimes fix unexplained clicks and crackle.

But I would try another machine first, if you have one.


Gale, thanks for these suggestions!

Does it only happen when you’re speaking? It’s very difficult to hear problems buried under your presentation. If they’re frequent enough, ping a wine glass and hold it up to the microphone. That will give a pure tone and it should stay pure until it dies out completely. Anything that’s not pure tone should be obvious.

We’ve been calling it a click, but at the beginning of this thread, you called it more of a tiny water drop.

a little like a tiny drop into water,about every 20 seconds (though not regularly)

Straight digital errors or other brief but serious disturbances all tend to sound like Tick or Click, basically the system running crazy for a brief time and producing all frequencies—a really tiny white noise.

That may not be what you have.

Without going through the whole thread again, have you tried the microphone on a different computer?

I was able to locate a source of hum in my studio a bit ago by waving the microphone around slowly and listening to Audacity in Monitor (live) mode. As I got closer to my badly behaved bass cabinet and amplifier, the him got much worse.