Audacity Already Running

My computer is Windows 7 Home Premium 32 bit. I have been using Audacity for some years without trouble. Four weeks ago I downloaded the new version Audacity 2.0.
I keep getting the message The system has detected another copy of Audacity is running.
I have checked Programmes and searched for additional copies without success.
I have deleted Audacity 3 times and re-installed it still with the same problem.
After searching for an answer on the internet and changing Preferences (User/AppData/Roaming/Audacity) and deleting all except
NewPrefsinitiated - 1. I still am no further in solving the problem.I have had four weeks of frustration and spent many hours trying
to sort out the problem.
Can you help?

Please tell me you restarted the computer from a dead stop at least once…


Each time I installed Audacity I restarted the computer. If you mean by a ‘Dead Stop’ a complete shutdown no, but I have since receiving your post removed Audacity (for the 4th. time), re-installed it and shut down the computer completely.
I have now powered up the computer and the problem is still there.

Just checking.

I see you’re using the Roaming install. Audacity used to have a “portable” install, I’m guessin’ that’s the same thing. Audacity is famous for leaving bits of itself behind when you uninstall it. Our line is you don’t reinstall Audacity by reinstalling Audacity. You delete or manage the config file and Audacity follows along like a puppy.

Is this machine an upgrade from Windows XP? Did you ever have Audacity 1.2.x installed? Audacity 1.2.x hid settings in the Dreaded Windows Registry, not in a preferences folder like it does now. It’s possible to have two sets of settings and mess everything up.

I personally would go looking for all the variations of preferences and program files destroying as I went. Are you trying to run Audacity over a network? Again, just checking. Audacity doesn’t like that very much.

Why are you installing “portable?” Any specific reason?


Thanks for your prompt reply.
My Windows 7 was upgraded from Vista.
As I have been using Audacity for some years without any problems I must have had older versions, the latest being Audacity 1.3 Beta.I almost certainly had Audacity 1.2 installed.
I am not running Audacity on a network - just this computer. I don’t understand installing “portable”. I just try to instal the programme.
If there are old settings in the registry can you advise me how to get rid of them?
I run Glary Utilities every week to correct registry errors, but this doesn’t mean it will delete useless Audacity settings.

The text needed to reset audacity.cfg is


Audacity will ignore what you say you entered.

You must quit Audacity before editing .cfg. If you have not added a “Portable Settings” folder to the Audacity installation folder then NewPrefsInitialized=1 will give Audacity fresh settings and 1.2 settings are irrelevant.

Do I take it that Audacity doesn’t appear when you launch it? Can you see it in Windows Task Manager?

You may possibly have a problem with VST plug-ins. Have you added any of those? You could try exiting Audacity then paste in the attached file (renamed to audacity.cfg) and say “yes” when Windows asks if you want to replace the file.

audacity.txt (55 Bytes)

Dear Gale,
Got totally confused so once again deleted Audacity and reinstalled it (5th.time!).
I did change Audacity .cfg (found in User/Brian/AppData/Roaming/audacity) to the settings as per your attachment.
There are four VST Plugins in C/Program Files/Adobe/Adobe Premier Elements 4.0. I have not added any plugins to Audacity.
I have not added a “Portable Settings” folder to the Audacity installation folder as I do not know how to. I would be grateful if you could explain to me how this is done. When I try to launch Audacity it initally doesn’t operate at all but eventually the dreaded screen “Audacity already Running etc.” appears. Audacity does not appear in Windows Task Manager.
Thank you for your help so far.

Audacity won’t look in C/Program Files/Adobe/ for VST Plug-ins unless that path has been set as a VST registry key. See: .

There is no need to do so.

So did this happen the first time you ran 2.0.0 or only a while after? If it’s a recent happening, have you considered Windows System Restore?

Also how you are launching Audacity exactly?

If it is not plug-ins that are the trouble, the next problem could be your audio devices. Is it possible to right-click over the speaker icon by the system clock > Playback Devices and take a screen capture (ALT + PrtScr) of the listed devices? Then click the “Recording” tab and do the same. Open Paint, paste each image in turn and save it as a .PNG file. Then use “Upload attachment” underneath where you post Forum messages to upload the image and “place it inline”.

You can also use Problem Steps Recorder to take screen prints if you want to take a number of screen prints and make notes. If the file that is produced is larger than the 1 MB Forum limit, you can upload it to any of these free file transfer services: .


It is possiable that your uninstall of the original Audacity did not get completley uninstalled, Here is a free program that you can D/L and run and it will USUALY pick up any left over old program, Programs that windows control panel does not always pick up, At l;east it can not hurt to try,

Revo Uninstaller

Then run your regestery cleaner

BTW be sure and do a complete shutdown after each procedure


This problem has existed from the very first time I downloaded Audacity 2.0.
I am launching Audacity by clicking on the desktop Icon. (I have also tried clicking on Audacity in All Programmes.
Neither works immediately - but eventually the dreaded screen “Audacity Already Running…” appears.
You may well be onto something with the sound system.
When I Right Click on the speaker icon I get options : Open Volume Mixer;Playback Devices:Recording Devices:Sounds and Volume Control Options.
Only Volume Control Options and Open Volume Mixer work.
I Cannot open Sounds from the Control Panel. That doesn’t work at all. (I’ve spent several hours Googling to try to find a remedy for this but am stumped. So unfortunately I cannot send you a screen shot.
Please do not give up on me - I will keep trying to get this wonderful (when it works!) programme.

Thanks for your suggestion. I followed your instructions to the letter. I am quite impressed with the uninstaller programme by the way.
I did pick up some leftovers , but the final outcome is still the same.
Audacity does not work as it should.

We keep backing up to more and more basic problems. Did you get your new Audacity 2.0 from here:

…or somewhere else? Who made your Virus Protection Program and is it up to date? Can you run your virus program in “thorough mode” where it makes you stop using the computer while it’s working? Go make coffee or something.

And stop reinstalling Audacity for a while. You might be doing more harm than good.


Hi Koz,

Glad to hear from you again.
Initally downloaded Audacity 2.0 from sourceforge and on the next three occasions.
The last two times I’ve downloaded from CNET

My Antivirus is Avast Free Antivirus which runs constantly. I have just checked and is is right up-to-date.I never have to stop using the computer while it is running.
I used to use AVG free, but five months ago a computer engineer deleted it and installed Avast.

Are you permitted to use TeamViewer to assist?
Am I the only person with this problem?


If you right-click over the speaker icon and Playback Devices and Recording Devices don’t respond, your system is already pretty broken. Audacity is unlikely to play, let alone record in these circumstances if the sound device is actually the cause of the problem.

Did this computer engineer reinstall Windows or put a new hard drive in? In that case he may not have (re)-installed the sound device properly. I suggest you read and follow the advice there, in particular looking in Windows Device Manager for audio devices. If there is no audio device or it only has Microsoft drivers, look for the drivers CD that came with the computer and reinstall the audio device. Otherwise you’ll want to go to the web site of the computer manufacturer (if it is a branded machine like Dell or Lenovo) or the motherboard manufacturer and obtain a Windows 7 32-bit audio driver that is meant for your exact computer model.

Another possibility is that security programs are actually interfering with Audacity and Windows. Are you running any other firewalls (you should only run one at a time), or any other antispyware or security programs?

Taking remote control of your computer is certainly one possibility if you give permission and accept all the consequences thereof, but I think you have other problems to sort out first.


It does seem that the sound divice is causing the problem.

My computer is a DEll XPS 430 - originally using VIsta, but as soon as Windows 7 became available I converted the operating system. This was very easy to do and I had no problems after that.

Six months ago my C Drive packed up and an engineer replaced it with a Samsung 1TB drive.
He was able to recover all my files and most of my programmes. I cannot remember if I used Audacity Beta after this and before installing Audacity 2.0.

I have read the Audacity advice. I have checked Windows Device Manager audio Devices and checked the drivers. They are all up-to-date as far as I can see. I tried the original installation CD but could not find the Audio Device. I was also concerned that this would be for Vista, not Windows 7 32bit.

I then spent hours trying to find the Dell driver applicable for this computer for a Windows 7 operating system but was unsuccessful.

The only firewall operating is Windows. I also have Windows Defender, but this is switched off.

If you are able to take control of this computer I would be delighted as I am getting to the stage where I am considering using a sledgehammer on the wretched thing.
My telephone package allows me to phone land lines in most countries for up to an hour at a time at no extra cost if you need a code to connect to the computer.
I also operate with a dual screen.


He was able to recover all my files and most of my programmes


Why would he (the Engineer) recover PROGRAMS, when a program is loaded it is put in a certian place for the computer to find it and then added to the regestery, if the program is not properly installed you don’t know what will happen to it. Changing the HDD will completley change the address of programs and you will not even be able to locate them on the computer. Have you had any problems with other programs?

Now you know why many people start fresh with each new operating system upgrade.

Virus Protection programs do run in the background and on-the-fly inspect incoming and outgoing files for health and a match to the virus profiles. It’s all largely out of sight, out of mind. But. It’s not going into all the heavy duty system files and preferences and link libraries because you’re using them. In order to do an exhaustive inspection of your machine, the system has to stop and that means you get to make coffee.

If your virus software has no provision for exhaustive inspection, I bet it does in the high quality paid version.

You might throw yourself open to Microsoft’s on-line virus inspection.


I have used Avast for years. The free version is quite powerful, and includes the ability to do an exhaustive scan, including a boot-time scan (an in-depth scan of all files and the boot sector before Windows starts). The only things that you get from the PAID versions are a sandbox, additional firewall options, and spam-blockers for e-mail.

It’s always a good idea to periodically do a full scan - but I don’t know if that will actually solve your problems.


The only audio driver I could find for XPS 430 on the Dell site was which seems to be for a Creative Sound Blaster XFi card - is that what you are using, that is there is no built-in motherboard sound device? Another way to get information about your audio devices is to click the Windows globe, type “dxdiag” (without quotes) then run dxdiag.exe when it appears in the search results.

When you went to the Dell site did you enter or let Dell detect your “Service Tag”? See . This may give you a better chance of identifying any drivers you need.

If I was in your position and drivers provided no solution, I would try a system restore to before you installed Audacity 2.0.0 (or to before then).

If that did not help, I would disconnect the internet, exit Avast (not the firewall) and other security programs and see if that made Audacity run. Anti-virus and anti-spyware engines can prevent programs and interface elements of Windows launching.

Then whether you have success or not, I would do a full boot-time virus scan using Avast!

If that did not help I would reinstall Windows. It is quite easy to reinstall Windows 7 while keeping your program settings and files (though of course you should backup your files before reinstall).

If that solves the problem then you could create a system image using Windows Backup and Restore which will give you a working system (ready to go with drivers installed as they were) which you can go back to if your hard drive fails again.


Thank you all for your advice and assistance.
Yesterday Audacity finally worked - and today it is still working.

Thor 21344
“He was able to recover all my files and most of my programmes”
I regret if my information was confusing. When the computer enginner replaced my C Drive with a brand new one he was able to recover all my files and nearly all of the programs installed on the old C Drive which were in C/Program Files.
I have had no trouble at all with any programs until I installed Audacity 2.0, which is the only program that has not worked.

As a fairly newcomer to computers and without formal training when upgrading from Vista to Windows 7, I followed the instructions on the installation disc.(I was installing Windows 7 Home Premium, not the Professional version which would have meant a clean instal).
I had no difficulty in the conversion and everything has worked fine until Audacity 2.0.
Thank you for your information about Microsoft’s on-line virus protection which I did not know existed. I downloaded the program and ran a full system scan.
This ran from late morning until well into the afternoon. No malicious files were found.

Your information about Avast was very useful. I did a full system scan which took ages. Fortunately no malicious files were found.

Gale Andrews
Thank you for your perserverance. I did use the Dell Service Tag when trying to identify a driver for the sound, and like you came up with just the Creative Sound Blaster which I’m sure was not on my system . I was reluctent to download it as I have now upgraded from Vista to 7.
Befor resorting to System Restore I followed your instructions by disconnecting form the internet and exiting Avast. I then did a computer restart, restored Avast and re-connected to the internet.
I then clicked on Audacity symbol on the Desk Top and AUDACITY OPENED!!!
I could hardly believe it, so I closed Audacity and re-opened it again, and again, and again. Each time it worked.
Today I tried again (I could hardly believe the solution was so simple) and it is still working.
So no need to reinstal Windows 7.
I will certainly be making a back-up. I use Genie Timeline and a seperate 2GB drive for back-ups.
I am extremely grateful for all your assistance.

I knew nothing about computers until six years ago. I am now aged 75. After buying a digital camera wanted to improve the pictures. I used to print them at first, but that proved very expensive so I learned how to burn them to a DVD. I then wanted to produce slide shows with tranitions, captions and music. Hence Audacity.
Next I wanted all my friends to be able to view the shows, so I learned how to build a web site (

Once again thank you all.

Brian Wilson.


I’m glad Audacity is running. How about right-click over the speaker icon > Playback and Recording Devices?

I don’t know what inference to draw, except possibly that the heuristics Avast! employs to block viruses were getting tangled and needed a restart while Windows was running.