Audacity adding extra audio when I copy/paste.

I thought 2.0.3 would fix this, but it hasn’t. When I try to copy and paste to create a repetition of a particular piece of an audio file, extra audio gets added on to the ends of the pasted segment. How can I prevent this?

Please describe step by step how we can recreate this problem.

Of course. And, apologies for not stating initially, but I’m on Windows 7, and I’m having to use the .zip currently. Though I had the same problem with 1.3, and it’s actually installed.

Take an audio file. A song for instance. Select the part you want to repeat. Copy it, and position the cursor where you want it to be copied, and paste. If you do this enough times, you’ll notice it add on small, but noticeable amounts of audio to the ends of the pasted portion. I can provide pictures as well for clarification, if you’d like.

No I can’t reproduce that problem.
When you say “If you do this enough times”, what actions are you repeating? Are you just repeating the “Paste” operation or are you repeating the "Copy " and then the “Paste”?

Do you have “Snap To” enabled in the Selection Toolbar?
You probably don’t want that enabled.

If you just want to repeat one section over and over, end-to-end, you can use the “Repeat” effect:

I still don’t understand what Snap To does, but I will turn it off if it is on and see if that helps, as well as trying the repeat function, and report back.

The easiest way to see what “Snap To” does, is to set the time units in the Selection Toolbar to “seconds”. To do that, click on the little black arrow at the end of one of the time display boxes, then select “seconds” from the list.
Then, with Snap To enabled, click and drag across the audio track to make a selection. You should be able to see that the edges of the selection “snap” to the nearest exact second.
Then disable “Snap To” and you should see that you can now select between whole seconds.

The purpose of “Snap To” is to allow you to select exact whole units of time, such as seconds, milliseconds, frames, or any of the other time format options.
Normally you would want “Snap To” disabled.