Audacity 3.x Unusably slow

I’ve spent the better part of the last week and a half struggling with Audacity’s impossibly slow performance. This is a project I first worked on in May last year (2023) and was looking forward to doing it again. Here it is in a nutshell

Sound recordings from an audio board at a live performance
Each set was around 10-15 minutes long
30 channels (31 this year)
Each multitrack wav file is just under 2GB.
Imported into an aup3 file about 3.8GB

I can’t be sure at this point, but I think I was using Audacity v3.1.3 on this project last year. All went well. Sure some things took time to process but nothing unbearable. It was fun!

As I started in on it this year, it became clear something changed. Windows upgrades are just about all I can think it would be. After just one or two really simple edits, I found myself waiting 15 to 60 minutes before Audacity would become responsive again. I discovered for the first time what happens when Audacity crashes in the middle of a process. It was just horrible.

I saw there was an update. Surely this is something that was addressed! v3.4.2 was even worse. I simply could not get anything done at all. I spent the last week or two trying to come to a solution. Running the program in various compatibility modes with reduced colors. Don’t have it open in a full window. Uninstall/reinstall. Nothing worked. After only a minute or two of the simplest edits, Audacity came to a screeching halt and more crashing and burning. I even tried out some alternatives (Reaper is blazingly fast, but I couldn’t wrap my head around it). I really want Audacity to work.

And it looks like I might have found a solution. At a guess, I looked for older versions and I saw that v3.0.2 was the last 32-bit version released. It’s working great. Not Reaper-level speeds but certainly not painful and quite usable.

Once I’m done with this project I might do some more experimenting. But in case anyone else has been experiencing these sorts of issues, perhaps my story will be helpful.

Audacity is an awesome product and I’ve been enjoying using it for some time now. Hopefully someday I’ll be able to upgrade to a more recent version.

If you’re not sure, which version you used before (maybe lower than 3.1.0?), this might be an issue with the “smart clips” that were introduced with 3.1.0.
I had to revert to 3.0.5 because editing larger projects became practically impossible.
So - unless you have an actual reason to use one of the later versions, you should maybe try downgrading and see how it works for you.
The “smart clips” cause any split to produce two copies of the entire original clip. As soon as any effect is used on one of these, it doubles the memory used for that portion of the recording.
So - if you have a 10-minute clip, and split it anywhere, then do anything to one of the parts, you suddenly have two 10 minute clips stored.
This makes editing larger projects practically impossible on even powerful hardware.
So far, the team seems to deny it’s an issue, so I don’t think it will be resolved at all.

Thank you @Gilmir – as mentioned I downgraded to v3.0.2 thinking it might be a 32 vs 64 bit issue and that really did help. Maybe at some point I’ll try moving up to just under v3.1.0 when I’m less frustrated. At least for now I think the situation may be workable.

I did note the aup3 file would balloon alarmingly after just one or two simple edits. The idea that I would have to do an edit that takes 7-10 minutes to execute. Then another 15-20 minutes just to save and close the file so I could move on is absolutely ridiculous. I was thinking Audacity has a memory leak of some kind based on the quick deterioration of its performance. What you’re describing sounds something like a memory leak, except it’s on purpose. Some way to disable this feature so I could actually get some work done would be extremely helpful.

I still wouldn’t be surprised if something has happened with a Windows update or some other program leaving bits of itself lying around in memory. I’ve had indications from other programs that something more general may be going on with my system.

Thanks again for your input!

Followup on the tragedy of Audacity.

Thanks to @Gilmir’s suggestion, I am now using v3.0.5. This pre v3.1.x version is usable but still causing severe headaches.

Reminder, the projects I am working on are ~30 track live recordings taken from the sound board. Each file is around 10-15 minutes long.

While usable, I often find myself having done something that will cause Audacity to completely hang up. Task manager shows it as ‘suspended’. Even more often is Audacity reported as ‘Not Responding’ both in Audacity window titles and the task manager. When I’m lucky, it eventually comes back and processing whatever it is Audacity feels the need to process.

So I’m being trained by Audcatiy to not do too much at once. quitting whenever possible as restarting seems to clear whatever it is Audacity has gotten all hung up about. Sometimes the hang up is so bad, I need to shut down my entire system. Although it seems unreasonable, even choosing a restart doesn’t seem to be as effective as, shutdown, take a breat, boot.

Interestingly, even if I manage to escape the clutches of Audacity and completely close it out, a simple system shutdown can take 3-5 times longer normal.

I am writing this message because I’ve spent the day fighting Audacity over these weird hang ups, not-respondings and extremely slow processing and right now, having just completed a single effects operation on around 10 tracks simultaneously (repeated hangups along the way, but it finally accomplished the mission) I have attempted to save and close the project and the current estimate is around 50 minutes to ‘compact the project’.

I am slowly learning:

  1. Don’t try to do too much at once
  2. Close Audacity often
  3. if needed shutdown the entire system to clear whatever it is Audacity has done to screw things up

In all cases when Audacity reports ‘suspended’ or ‘not responding’ CPU usage is at or near zero. Same with disk activity.

What the heck is Audacity doing while there seems to be no activity whatsoever on the system as a whole?

Audacity pre-v3.1.x is almost usable but a great and terrible PITA.

I am thinking I will try working on one of these files on my Mac. Perhaps Audacity plays nicer with the MacOS?

This is so frustrating because Audacity is otherwise perfect for my needs. But it might be time to look again for alternatives and just shell out the cash for something that isn’t so mind-bogglingly nasty to my OS

I have no help to offer, simply here to say I’m having the same issue. I edit a game my friends and I play, six tracks in total, 5 vocal 1 background music, Audacity used to be fantastic. Now I can’t even change the height of a track without the program freezing up for minutes on end. RAM and CPU usage is low, but disk usage is at around 50% for just Audacity and I cannot figure out why. I have smart clips turned off, I don’t really use plugins, I’ve cleared out all temporary files and even deleted a project I wanted to go back to but am trying to clear things. Everything else on my PC runs perfectly. I can play a video game, listen to music, and run a Virtual PC all at once without issue, yet Audacity makes me feel like I’m working on a 1980s Macintosh.

I honestly keep trying to find software that won’t make me worry my expensive computer is about to explode, but nothing has been as idiot-friendly as Audacity. I wish they’d at least acknowledge this issue.

Unfortunately, there’s no option to “turn smartclips off”.
For no reason explained to anyone, you can turn off the "smart"clips feature on importing them (pasting from another project), but not within a project.

The only workaround is to join everything you can (removing cut lines within the project), save, close and reload the project.
This should reduce the “footprint” of the project enormously as it removes all the “smart” information AND your undo history. Both together can cause the project size to literally explode, causing any PC to behave like an ancient calculator.
Sadly, this problem (although it comes up frequently on the forums) seems to be a “non-issue” for the Audacity team.
Personally, I suggest downgrading to a version before the “smart” clips were introduced.

bzak is there any chance you can share the project with me?

My issue was slow startup on Windows

This seem to solve the issue if you are patient and get Audacity to Launch. You will need to check and find what the default sound in my case it is 48000 and 24-Bit


Once it does, under Audio Setup, Select Rescan Audio Devices. Once done, next step
Still Under Audio Setup → Audio Settings

Set the Host to Windows DirectSound/MME
Under Quality
Set the project sample and default rate to 48000 HZ and 24-Bit
Click Ok and restart Audacity

This time it launched without issue. Repeated and much better. Not sure this will help

@crsib - I’d love it! Especially if it leads to a resolutions of these issues!

What would be the best way to do that?

You can upload it to Google Drive or Dropbox and share the link with me in private messages.

Thank you!

@crsib I don’t seem to have permission to send private messages

Thank you for access, I am looking into. The problem is definitely not in smart clips, you have none :slight_smile:

@bzak, well, I am afraid this is a “known issue”. I will try to rush a fix into 3.6, which will give some 7-10 times speedup, which is not quite enough but still will yield more adequate results.

It’s pretty odd that you experience slowdowns when updating Audacity versions, the painting code was not really touched a lot for the last 15 years or so :slight_smile:

Unfortunately, right now, Audacity doesn’t work too well on modern high-resolution displays. In particular - the wider the window and the more tracks you have in view - the slower it runs.

PS. It is weird, that you cannot send PMs

PPS. I can open your project from SSD in 40 milliseconds when using Audacity 3.4.2 and in 35 when using not yet released 3.5.0. It take 77 milliseconds on HDD. Can there be an issue with your disk?

Audacity has two"magic" problems. It forms Edit > UNDO by memorizing the whole show. So when you step back, Audacity just opens up the last show. That’s also why you can’t undo out of order.

Audacity doesn’t deal with non-internal drives well. The more remote, the worse. It assumes that any drive it can see can be used for the most important, critical, complex jobs. Just try overdubbing from a cloud drive. Not happening.

It’s best, at least until 3.5, to disconnect external drives. Apparently, you can’t just ignore them.

New Forum Users are restricted to what they can post and how much. This is an improvement. It used to be New Users were completely mute until a certain number of posts.

Two more notes. Until relatively recently, this was the Audacity World Headquarters.

It was for affordable home editing and not intended to mix down a rock concert from an eight-foot (2.4M) long console.

The first thing that Audacity does with a sound file is convert it to 32-Bit Floating. You can force it not to, but it’s good that it does that because 32-floating doesn’t overload.

For one immediate and popular example, Audiobook Mastering Macro applies loudness normalization and then gentle peak limiting. Without 32-floating, the volume setting step would create unrecoverable peak distortion.


@crsib - Funny you should ask. A new experiment I’m running is disabling virtual memory. Initial results are promising but we’ll see. So far it seems like I can do more before running into trouble and I’m seeing ‘not responding’ less often. I’ll let you know after I’ve had a chance to work this way for a bit longer.

As for loading the file… the first time I open the file it takes a few seconds. Subsequent opens are near instantaneous. I couldn’t tell you the exact time.

fwiw I have
8G memory
15G free space on a 115G SSD system drive
320G free on a 950G HDD

While working in Audacity, in rough numbers, CPU and disk are generally pretty low. Memory something like 60% ish iirc. When Audacity stop responding and goes so far as to be suspended, there is nothing happening arrounding to the task manager. 0 cpu, 0 disk, memory still hanging around 60ish%.

I came across this while searching for a solution to multiple issues I was having with 3.4.2 being impossibly slow when recording audio, mute not working as expected, and some other issues.
I wasn’t sure if the problem was with Audacity or my new computer as Audacity 3.4.2 works fine on my old computer. Anyway, when I got on the forum I saw that 3.5 Beta was available and thought I would try that. It fixed all of my problems. Reading up on 3.5 it could be that it handles external drives better.
It may not be the solution to your issues but thought I would pass it on in case it helps someone.

As suggested, I tried the v3.5 beta. It looked so good for a while there. But two problems came up so I switched back to v3.0.5 which is actually working fine for me now that I disabled virtual memory. In fact my whole system is running smoother. I still have to make sure I don’t do too much before saving and closing the file. But it’s definitely very workable now.

Problems with 3.5-beta

  1. Playback constantly stops and starts
  2. Every time I made any edits then closed the file, Audacity would crash. The offer to send a crash report always failed as well. I could reopen the file, recover from the failure and continue on with work. But this got pretty annoying.

I also found that things went better if I uninstalled before installing a new (or older) version. Unfortunately, v3.0.5 can’t open files saved in v3.5. Thank goodness I keep careful notes so I could reproduce what I had done.

Thanks for your efforts looking into this. As I went looking around for alternatives, Audacity really does make the most sense for my less-than-amateur efforts.

This topic was automatically closed after 30 days. New replies are no longer allowed.