Audacity 3.x GUI doesn't handle high-rez monitor & large fonts well

So I’ve just upgraded to Audacity 3.3.3 on my Linux Mint 21.2 desktop (3.4.0 can’t hack my old 2.4.2 files). 3.3.3 works fine so far as I can tell, but the GUI really can’t handle a 4k monitor. I’m using two different 4k screens, my Dell XPS13 laptop screen and a Philips Brilliance 272P, both set at native 4k resolution. With either monitor, Audacity 2.4.2 couldn’t really scale the action buttons right, but at least the fonts worked. I’d show you a picture, but as a new user the board will only allow me to embed one image. I’ll try the old image in a follow-on comment and see if it works.

Now look at 3.3.3 (3.4.0 is the same) on the same monitors, and note that the buttons, though tiny, are cleaner, but the VU meters are using enlarged fonts and show only one channel. Likewise, font and tool scaling around other elements of the toolbar are screwy:

While this is probably small potatoes in the bug world, it does make for pretty fugly interface, and it would be nice if this could be refined in future releases.

Audacity is currently porting it GUI from wxWidgets to QT, which is expected to be released with Audacity 4.0. See: HiDPI issues · Issue #503 · audacity/audacity · GitHub

Thanks for pointing out these other threads. I didn’t think of using the term HiDPI so didn’t find anything in the search. Looks like we’re gonna be waiting a while for 4.0 … anybody have a workaround other than switching to a lower screen resolution?

compiling from source (or using the version that comes with your distro) can yield a better UI than the appimage. Maybe it improves the scaling as well, but I don’t know for sure

Not sure why I didn’t think of that, but the Linux Mint Software Manager (as opposed to the Synaptic Package Manager) offers the option of the FlatPak which does handle the GUI marginally better (still not flawless, but usable). Thanks for the suggestion.

This topic was automatically closed after 30 days. New replies are no longer allowed.