Audacity 3.5.1 & ".opus" files: Won't do anything at "Import", and will crash at "Open"

Hello all!

I’m a newbie user here at the forum, a long-time Audacity user, though.

Before creating this new topic, I have searched and read other topics with similar issues, but they were related to very old versions of Audacity, so I’m not sure if those issues are related to this one, actually. Hence, I’ve created this topic now.

I’m facing not one, but two issues when using Audacity 3.5.1 (64-bit) on Windows 10 with .opus files. Instead of typing to try to talk about them, I have recorded two videos from my screen [with no sound], and uploaded them to YouTube.

The first problem is that Audacity will not import some of my Opus files. I will even try to recover it (will show the Opus file as Recovered, but nothing will be imported, actually).

The second problem happens when try to open the same Opus file. Audacity crashes and I can’t even send the report! :poop: So, I will attach it here.
AU_crash.txt (227,3 KB)

Am I doing something wrong? I apologize if this thing was previously reported.

Thank you so much for reading!

Well, I was able to solve these issues by myself. I’m replying to my own thread, just in case someone else have to deal with these problems.

So, this is how I managed to solve this thing:

  1. Close Audacity.
  2. Remove manually the installed files by the FFmpeg 5.0.0 binary installer for Audacity 3.2.0 and later/newer for Windows x86 64-bit (these are all the files that are saved at C:\Program Files\FFmpeg For Audacity, by the way).
  3. Download the ffmpeg-win-2.2.2.zip [direct download] file to any location/folder of your drive and then uncompress/unzip the .zip file (this FFmpeg v2.2.2 works with Audacity 3.x).
  4. Copy the 8 files to the location mentioned in step 2. Windows will prompt for confirmation. Go on.
  5. Run Audacity. It should have automatically detected these FFmpeg libraries. If you want to confirm that, from the Audacity’s menu bar go to: Edit > Preferences > Libraries > and click on the Locate… button. The FFmpeg Library Version should display: F(55.33.100),C(55.52.102),U(52.66.100).
  6. Finally, try opening or exporting an Opus file.

I hope this works for someone else that easy as it worked for me. :blush: