Audacity 3.4.1 - Audacity did not recognize the type of this file mp3

I’ve been using Audacity for years for simple audio editing but lately I am unable to open any MP3 files. These are the same files I’ve used to import into Audacity and now they no longer work. I 've been getting this error message.


I’ve tried converting to WAV and MP4 and it does not work. I’ve uninstalled and reinstalled but still no luck. Is anyone else experiencing this bug or is this a known issue for this update?

Audacity sometimes has trouble with “imperfect” MP3s. Or sometimes it’s not really an MP3 and Audacity gets confused.

With what?

Usually the easiest fix to convert to WAV with a 3rd-party tool and then open the WAV for editing. (Audacity is going to decompress the MP3 anyway.) I use Kabuu Audio Converter or TAudioconverter.

Another reason this may happen for this version is that now the exporter lives in the modules folder. Please make sure that the following files are present in a subfolder to the Audacity.exe called “modules”, which contains these files:

I used an online converter.

But my main issue is that my MP3 files had always been able to be imported before. Now I get this error message. Does that mean I have to re-download all of my MP3 files to be “perfect” MP3s?

I have all those modules.

But my issue right now isn’t exporting. It’s importing MP3 files, which are no longer working when they have in the past.

I misspoke, these are importers and exporters. If the files work after running them through converters, it’s an issue with the files.

But I’ve been able to import them before with no issues. Why could I import them before but not now?

Since no MP3 file works anymore, I have to properly re-download/convert them again?