Audacity 3.3.3 Won't Install

I have been unable to install Audacity 3.3.3 under Mac OS 10.15.7.

What happens is that just after I drag the Audacity icon over to the Applications folder alias, a pop up appears with the text “Preparing to copy to “Applications””. There is a progress bar in the pop up, but it never “progresses”.

At this point I have tried the following:
– Re-download the DMG
– Delete an old version of Audacity
– Let the install run overnight

None of these things produced any change in behavior as nearly as I can tell.

Does anyone have any suggestions for me?


There is a similar issue (with a workaround) posted here: Updating to 3.2.3 Gets Stuck on Verifying for older Macbooks (OSx 10.13.6 / Intel Chip) · Issue #4139 · audacity/audacity · GitHub

I found the audacity-macOS-3.3.3-x86_64.dmg download and am trying that. So far, I am getting the same results: Pop-up says “Preparing to copy to “Applications”” and "Preparaing to copy “”, but progress bar doesn’t move. A greyed out Audacity app appears in the Applications folder but its size is zero bytes. I will leave this installer running over night to give it a chance, but I’m not too hopeful.

I would agree with this sentiment. I’m a Windows guy but I’m thinking the problem lies external to Audacity. I would suggest trying a reboot to eliminate the possibility of remnants of Audacity running in the background - or some other issue. I did a search for this issue on the internet - some suggested just letting it run (as you are) others suggested running a disk repair.

Regardless, I have no additional ideas to offer. Perhaps someone else will step in. Please report back what you find.

The audacity-macOS-3.3.3-x86_64.dmg produced the same results as the other dmg when I tried to install it. I let it run to two days straight and nothing was copied into the Applications folder. I’m wondering where I can find some older versions of Audacity to try. I haven’t tried very hard to find these yet, but I will pursue that option when I can. If anyone can point me to the right place, I would appreciate it. Another option I have is to roll my OS back to the previous version. I was using Audacity before I upgraded to Catalina and had no problems then.

This is not an “installer”. It is just a copy of a file from one place to another. From your description it is not stuck on “verifying”.

Are you dragging the Audacity icon onto the Applications folder icon in the DMG window (which is an alias)? If so, try dragging the Audacity icon directly into your Applications folder.

This topic was automatically closed after 30 days. New replies are no longer allowed.