Audacity 3.3.3 on MacOS 12.4 Montery not saving/exporting

So I’m s***ing bricks here.

Done a bunch of work on a project, and it’s not allowing me to save the project as a aup3 file, or allowing me to export at all.

I think I know the cause - I let my laptop run out of battery before re-charging it - I’ve seen a couple posts on here about that.

I’ve tried looking for the backup/recovery files in my directory, but I couldn’t find the folder, so I tried to add it on the file path that it had selected, but that doesn’t seem to have worked.

FYI - the temp file directory location that was selected in Audacity was “/Users/myname/Library/Application Support/audacity/SessionData” - the ‘audacity/SessionData’ folders did not appear, so I created them.

I had this problem before, and thought it was a one-off, but when I closed Audacity down, having copied the waveform, thinking I could paste it back in once I re-opened… didn’t work. So I’m stuck.

Any help - to re-enable saving, or to find the temporary snapshots, in any form appreciated…

Good plan :grinning: Unfortunately, any audio “copied to the clipboard” gets deleted when Audacity exits. I don’t know why. Possibly because data never gets copied to the clipboard - this behavior is just simulated.

OK; you have a serious problem here. If I recall correctly some related work was done for 3.4.0, so this problem may have already been fixed. Unfortunately, your timing is not good. We (as in you and I) are going to have to try to reproduce this in 3.4.2 when it comes out, as 3.4.0 and 3.4.1 are just a tad buggy yet.


I found a solution!

I used the “Export Multiple” function, and was able to get it exported into the folder I needed to get it into as an mp3. And the mp3 WORKS.

I haven’t yet been able to import the mp3 back into Audacity (and it seems the issue also extends to importing things as well), but I think once I restart Audacity, I should be able to import, and continue working… fingers crossed!