Audacity 3.3.3 Noise Gate Not Working!

I have installed Audacity 3.3.3 but have found, like a previous version bug, that the Noise Gate does not work at all!
No matter what settings I adjust and how many db I set the level reduction to, it has no effect whatsoever.
I am using Windows 10.

This works for me - but not with the default settings: Presets and Settings > Factory Presets > Defaults.

After I changed the Gate threshold (dB) from -40 to -20 it worked like a champ.

In the Noise Gate effect, click on the “Preset and Settings” button and select “About”.
The version number should be “3.0.4-1”.

Yes, that’s the Noise Gate version I have, which sadly does not work, no matter what parameters are changed.

I tried that and it worked when selecting one breath noise to remove, but when I applied the noise gate with those settings to the whole file it didn’t do anything. Bah!

As a test, try this:

  1. Close Audacity if it is open and restart Audacity.
  2. Generate a 30 second tone, 440 Hz, amplitude 0.8.
  3. Apply the “Fade In” effect to the entire track.
  4. Apply Noise Gate to the entire track with these settings (All defaults except for “Gate threshold (dB)”):


Cheers Steve, I’ve done that, what should have happened? Nothing seems to have!

How long is your selected audio ?

20 mins. Though even on a shorter 30 second clip it still doesn’t work.

The quiet part should be quieter and the fade-in should no-longer be “smooth”.

Maybe you don’t understand how a noise gate works. It only has an effect when sound is quiet (below the threshold). It makes quiet parts quieter or completely silent. (Ideally, those quiet parts are only background noise.)

A noise gate is a rather “crude” effect and it can often be annoying or distracting.

It should work for everybody because it’s a Nyquist effect… Nyquist effects are run by Audacity itself so they don’t depend on your operating system or anything else.

I know how a noise gate works, which is why I’m certain this one doesn’t. It works on a short section, a single isolated breath, but when applied to the whole file it has no effect on the audio whatsoever.

Might I suggest posting your audio file - and an image or snapshot of the parameters you are using.

here is some screen grabs of my process and parameters used. I select the breath noise, add my noise gate preset I have configured, it reduces the breath noise, I undo the noise gate, select the whole file, add the same noise gate preset to the whole file and…nothing happens.

This is what should happen:

Check that all of the settings are the same as the screenshot that I posted.

Try using other Nyquist effects (such as the Delay effect, High Pass / Low Pass filter, Rhythm Track (“Generator” menu), Adjustable Fade …). Do any of them work?

Is there a threshold? Start with the single breath and get longer until it stops working. You could also do the “half-way progression” thing. Select work half-way between a breath and full. Then half again, depending on whether or not it worked.

It is possible you’re running out of machine to do longer jobs.

That’s where I’d be going. You could be surgically watching one failure when there are a number of other failures on your machine.


Try changing your Attack Time to 50ms. See: Noise Gate - Audacity Manual