Audacity 3.2.3 and searching for plugins

On Arch Linux, I’ve just upgraded audacity to version 3.2.3.

Now on start up it searches for plugins. After several hours of searching for plugins it crashes without starting.

So how do I start but force it not to search for plugins, from the command line, or config files?

When the plugin scan freezes, click the “Skip” button and the scan will skip over the unsupported plug-in. Continue skipping as necessary until the scan completes.

As far as I’m aware this is the only way to deal with the issue, (other than using an older version of Audacity).

Ah problem there is only occasionally does “Skip” become ungrayed, and can be clicked. I’m not sure how many plugins its scanning - but seems to be 100’s - so need to skip 100 of files. Just leaving it chugging along to start up - doesn’t really help either - its over 2 hours of scanning so far.

So what this says is that 3.2.3 is unusable on my machine, so I’ll look at downgrading, or changing to another tool. Only really used it for doing an FFT of several 100s of music, as it gave a quick way of finding all active notes in a song, and so typically the key signature.

You could try the current 3.2.4 version: Audacity ® | | Download for Linux

Yes plan to try 3.2.4 when it comes out on arch. Its been changed in the arch source code, but that still hasn’t yet made it way out into the distributed binaries. Arch usually does that quickly, so as probably only a few days wait, that easier than compiling myself.

Of the options tried, audacity was by far the easiest to quickly get all notes used in a song, to about semitone accuracy - haven’t found other software than can do it nearly as easily- so it would be a pity if I’m not able to use it any more.

No need to wait, or to compile it yourself. You can run the AppImage and isolate it from your installed version in the following way:

  1. Create a folder somewhere convenient in your home directory.
  2. Download the 3.2.4 AppImage into the folder.
  3. IF the download is a ZIP file, extract it so that the AppImage is in the new folder.
  4. Set the file permission of the AppImage to “executable”.
  5. Open a Terminal window in the new folder (or open a Terminal window and cd to the new folder)
  6. Run the command:
./<name-of-AppImage-file> --appimage-portable-home

That will create a “home” directory for the AppImage so that it doesn’t pollute your installed version.
7) Run the AppImage (double click on it)

3.2.4 from the AppImage is still quite slow - am leaving it running to see how long it takes.

My problem is libraries like ladspa, so /usr/lib/ladspa on arch has 201 .so files - audacity tries to check every one, and take a fairly long time doing so on each.

That seems rather strange. It only takes about 30 seconds on my machine, even with a lot of plug-ins installed, though I do have to skip one plug-in.

OK did eventually get audacity to start up from the AppImage - had to point it to used x11 (then it didn’t crash the session), and leave it running overnight.

When it eventually came up, it showed 1299 incompatible plugings - I attach the full list if it helps.

So I guess the question is, will it remember all the scanning it did this time to start up, and not do it again, or will it do it every time it starts up?
Audacity-plugins.txt (53.4 KB)

That’s weird, some plug-ins that I use with Audacity are in that list. :confused:

Those are the default ones that come in Arch, e.g. things like ladspa:

Let me know which plugins on the list worked for you - I’ll check owners, and see if there is a pattern.

Audacity does not have much support for “instruments” other than the built-in generators and Nyquist plug-ins, so my comments below refer to “effects” that process sound and not “generators” that generate sound.

Most of the “SWH” (Steve Harris) LADSPA plug-ins work for me.
Most of the “TAP” LADSPA plug-ins work for me.
Most of the “Zam” plug-ins work for me.

I don’t use VST plug-ins, so no comment there.

Calf LV2 plug-ins (effects) work, except for the “vinyl” effect.
Most MAD plug-ins work for me.
Guitarix LV2 mostly work.

“blop” plug-ins are ancient and very buggy - I wouldn’t recommend them at all.

Still need to check those plugins have been compiled properly - but what I did notice (when starting audacity 3.2.5) is that audacity program is causing a lot of core dumps (at least that is what systemd is saying). Need to work out what systemd has done with the dumps, and process with gdb - hopefully the audacity program hasn’t been stripped of debugging info.

Anyway short of time here, but I’ll keep digging when I get time. For what its worth, once audacity comes up (after something like 11 hours), is I can use it just as I used to use it. For me it simple processing, select a passage, do an fft at a high number of samples, and pull out the notes. So I’m not doing anything all the complex once I get into it.