Audacity 3.1.3 not working in Ubuntu 18.04.6 LTS [SOLVED]

Using Ubuntu 18.04.6 LTS, Audacity 3.1.3. Audacity has never worked, I don’t know why. Audacity does open. But if I open Audacity and then open a sound file (mp3) and click to play it, nothing happens. It doesn’t play, nothing moves. It is not merely that there is no sound; nothing at all happens. The cursor doesn’t even move.

Are you using the AppImage from here?

I am using the distribution’s release.

According to this page (, the distribution release is Audacity 2.2.1-1

I installed the distribution release. Whatever updates came over time with Ubuntu have yielded the version you see here–Audacity 3.1.3. Distribution release is the only software I use. Not by policy, but by convenience. If you have any suggestion as to how to get it working, let me know.

My guess is that you have the Snap Store version of Audacity.

Try uninstalling Audacity, then download Audacity AppImage from the Audacity website:

To use the AppImage, put it somewhere convenient, such as your home folder, and change the file permissions so that it is executable. You should then be able to run it either by double clicking on it (easiest), or you could create a Desktop launcher or add a menu item to launch it.

I have never heard of “Snap Store”, and have certainly never used it. I
I had installed Audacity using the “Ubuntu Software” app, which is the tool supplied by Ubuntu for installing software supplied by the official Ubuntu release. And I have just used the same “Ubuntu Software” app to uninstall Audacity now.

I installed Audacity now using the link you provided for the Applmage, and changed the permissions as you have instructed. Audacity is now working perfectly. Many thanks for your guidance – problem solved.

  1. Is there a way to mark threads as “solved”?
  2. For my knowledge going forward, is there a way to edit a post after it has been posted? I did not see any option for that on this forum.

Just add “[SOLVED]” to the end of the Subject line (as I have done here).

I think this becomes available once you become a regular forum user, but it is much preferred that you don’t.

Modifying posts after they have been posted can make topic threads confusing or impossible to follow. Much better that you just make a follow up post to correct or add further information if required.

You’ve probably used it without realising,

Ubuntu’s (horrible) Software Center not only pulls in software from the normal Ubuntu repository, but may also pull in snapd packages from the Snap Store. There used to be an option to tell it to use the normal repository only, but I don’t know if that option still exists.

Got it, thank you