Audacity 3.1.3 not picking up mic / recording

I’m operating on Windows 10 Enterprise.

I’ve recently upgraded to Audacity 3.1.3 and have ran into problems…

Everything is ok if I import an MP3 i.e. I can see and hear the waveform, edit and save etc.

The problem arrives when I try to record, it simply doesn’t pick up my (internal) microphone and I get a flat wave form.

I’m set at MME / Digital Audio Interface (USB3) / 2 (Stereo) Recording / Speakers (High Definition Audio). Have tried other permutations to no avail.

Everything worked ok before on this configuartion, so what’s wrong this time?

I can record fine with OBS Studio, so my internal microphone is working ok.

Am I missing something?

it simply doesn’t pick up my (internal) microphone…

…Digital Audio Interface (USB3)

The USB interface is NOT your internal microphone. :wink:

If you want to use the internal microphone and you’re using the laptop speakers, what’s the interface for?

And if you want to use an external microphone plugged into the interface, does that work with other applications? If not, tell use exactly what interface and microphone you’re using. If you have a studio condenser mic, make sure 48V phantom power is turned-on on the interface.

You can also check your [u]Windoes Privacy Settings[/u].

Hi Doug, thanks for reply. Sounds like I’m using the wrong terminology.

I’m not aware of any microphone per se. Whatever is inside my desktop to record audio onscreen is what I’m talking about.

OSB (attached) has the audio graph bouncing and it says it’s using “Digital Audio Interface (USB3)”.

The only other option I’m offered in Audacity is “Microsoft Sound Mapper - Input”, but selecting that gets no result either.

It was working fine before this upgrade, so I’m kinda baffled and have been messing around for days on the problem.

I must be missing something simple…

I’m still unable to record whatever is playing on my computer which is a crucial thing for me.

The recording timer starts to run, but just getting a flat line / no pulse from the audio graph.

Surely someone else must have experienced this?


To record the sound coming out of the computer select WASAPI as the audio host …
https ://

Thanks for the pointer Trebor. I went back to it and tried different selections and eventually got a hit, thank you.

For anyone else in the same position who might stumble into this frustration, this would be my advice…

Between host / playback device / recording device there were, for me, 20 permutations of options and only 1 worked. For you, there may be more or less permutations depending on what’s on your own device.

If you don’t understand what each means it really means having the patience to methodically go through the permutations one by one until you get a hit.