Audacity 3.0.4 Freezes During Capture From Audio Interface

I’ve been working on this problem for almost 3 weeks off and have run out of ideas. Any ideas or thoughts on what to try next would be greatly appreciated. My hope is that I’m doing something really stupid and someone smarter than me can help :smiley: . Thanks in advance.

When I open Audacity and attempt to start a recording or begin monitoring using the 4 channels interface as the input the application freezes within a second or two and I have to force quit the application. This happens almost all of the time. Approximately 1 out of 10 tries will let me proceed for a few more seconds before crashing or I might even be able to complete a capture of 3 or 4 minutes. The interface works properly in Logic ProX.

What I’ve Tried:

  • I’ve tried adjusting the buffer from a low of 20 to a high of 750. No difference.

  • I’ve tried connecting directly to the iMac on different ports and through a Thunderbolt dock. No difference.

  • I’ve tried various sample rates from 44100Hz to 192KHz and default sample formats of 32 bit float and 24 bit. No difference.

  • I’ve checked the Apple MIDI control panel to verify the interface settings match Audacity.

  • I’ve completely uninstalled and reinstalled Audacity multiple times. No love.

iMac Specs:
iMac Pro (2017 - iMacPro1,2) 3 GHz 10-Core Intel Xeon W, 128 GB RAM, 4TB SSD, macOS Monterey 12.0 Beta Build 21A5506j

Audio Interface:
BEHRINGER Audio Interface UMC404HD connected via USB directly to the iMac

Audacity 3.0.4

The iMac has a built-in microphone, right? Can you record from that?

Do you have iCloud or any other storage or “drive” other than the built-in? Is the built-in an SSD?

I’ve completely uninstalled and reinstalled Audacity multiple times.

Reinstalling Audacity doesn’t “reset” Audacity. Audacity keeps configurations and settings around in separate folders to make upgrading easier. The Windows Audacity has provision to automatically blow it all away and start over, not so Mac and Linux. There is Tools > Reset Configuration. That gets closer.

There’s also a way to go in and trash the configuration files by hand and I need to look that one up.

default sample formats of 32 bit float and 24 bit.

But not 16-bit?

Multi-channel (over 2) is an odd duck in Audacity. Not all interfaces work reliably.

Can you set up and capture in Stereo?


There’s another common error. Looking.


Audacity comes down as a Disk Image File .dmg.

You’re supposed to install it from there, but if you try really hard, you can actually run Audacity from the DMG file. It doesn’t go well.


Have you tried another OS version? Big Sur, Catalina?
OS Monterery, I mean, it’s beta.

macOS Monterey 12.0 Beta Build

Missed that one. There is no complaining about a non-release OS.


Thanks for the help! Here are the results/comments for the suggestions made to date. Other ideas? Thanks.

macOS Monterey Beta
I went with the Monterey Beta after seeing that others were having success with it. Last night I installed Audacity on another iMac that is running Big Sur. Same results. I’m going to spin up a Windows10 VM to see if the problem exists there. I know it’s not apples-to-apples but we’ll see what we find.

Uninstalling and Reinstalling Audacity
I uninstalled Audacity using AppCleaner. I’ve included a screen shot of what was removed. I also tried Tools> Reset Configuration.

Sample Formats
I tried 16 bit last night. Same results.

Does recording in stereo work
Recording in mono, stereo or 3 channel works reliably. It’s only when I add the 4th channel. It’s interesting to note that there is no problem importing 4-channel audio into Logic Studio so it doesn’t appear to be a core audio issue.

Built in microphone / other hard drive/cloud storage
Built in mic works. It’s an internal SSD. Tried creating the project on an external drive. Same results.

New information
For grins I tried Audacity 2.4.2. Same results.

Use Case FYI
I’m working to import and digitize old Quad 8-track tapes. I had a technician refurbish a 1973 deck which included a new output section and a realignment of the azimuth plus all of the normal items that would be checked / repaired / replaced. It actually sounds amazing and a lot of the source material is unavailable elsewhere.
Screen Shot 2021-09-15 at 12.09.07 PM.png

Was 48000Hz one of the various sample rates you tried?

Yes. Same results.

I set up a Windows 10 VM and a macOS Mojave VM to test the interface with 4 channels and it worked fine. The problem seems to be the beta of macOS Monterey. I’m guessing that other users on the beta are getting it to work because they are only using stereo. Since I’m on the beta I reported the problem to Apple through their feedback assistant and will wait to see what happens. I’m not too hopeful but we’ll see. If 4 channel recording still doesn’t work on the official release I’ll file a bug report with the Audacity team.

Progress Update

I may have found a solution / workaround for the issue on Mac OS with this mixer. If I disable Software playthrough of input I am able to record all 4 channels without the application freezing. I’m going to be doing a lot of recording over the weekend and will see if the problem is truly resolved.
Screen Shot 2021-09-24 at 2.12.51 PM.png

That should normally be disabled (off). (It is off by default).

Understood. The issue is that I would like to monitor Audacity through headphones and Software Playthrough of input looks like the only way to do this but it locks up the application. Would this be considered a bug as it only occurs when recording with 4 channels. 1, 2 and 3 channel Software Playthough works fine.

Sorry for the double post BTW. I posted this same reply on to help another user.

To monitor “Audacity”, enable “Play other tracks while recording (overdub)”.

If you mean that you want to monitor your microphone input, you do that from the umc404hd (headphones plugged into the umc404hd).

After testing over the weekend I feel that I have the issue resolved. The solution to my problem was to disable Software playthrough of input in the recording preferences panel when I’m recording 4 inputs (the maximum of my mixer). I normally leave software playthrough on so that I can monitor through the computer speakers but I can live with this.

Thanks to everyone that posted to help me out with this problem. It is much appreciated.