Audacity in Big Sur 11.4 won't open

After 11 years my second ever posting of a query! (So please let me know if I’ve misunderstood procedure)

Whether I try to open Audacity direct within Aapplications or from the dock, I get “Unable to check for updates”, with a line “Make sure you are connected to the internet.” I am connected to the internet. I am not able to open the application.

Audacity for Mac. (In applications, not dmg!) - current for today
Big Sur 11.4 - current for today
2020 Mac mini 8GB RAM
Ethernet on, fast network (Wifi turned off)

Have I missed something in installing Audacity? Can someone help me open Audacity?

Thanks for your help!

That sounds rather suspicious because Audacity does not check for updates.
Where did you get Audacity 3.0.2 from?

Thanks for your prompt reply. It was from here:

I decided to try one more thing - restarting the machine. This time, when I tried to open Audacity there was a popup saying I hadn’t downloaded Rosetta. I had gone to the Apple App Store and not found it. Somewhere along the way, the popup had gone. But when I restarted the Mac, after posting here, the Rosetta popped up again, I clicked on instal, and all has worked since.

So perhaps it’s the Rosetta thingy that works with the Big Sur-ity?

Is your Mac one of the new “Apple M1 Silicon Macs” ?


That explains it.
I thought that they would include Rosetta 2 by default, but apparently not.
The new M1 Macs can’t run programs that have not been compiled specifically for the M1 chip unless Rosetta 2 is installed.

The Mac release version of Audacity is not specifically built for the M1 chip (if it was, then it would not work for the majority of our Mac users that have Intel Macs), so M1 Macs must have Rosetta 2 installed.

When you were prompted to connect to the Internet, that was the macOS operating system needing to connect, so that it could download and install Rosetta 2. I don’t know why that initially failed, but there’s a lot about macOS that makes no sense to me :wink: