Audacity 2.4.2 on 11.1 on M1 MBA Headphones Issue

Yes I know this is kinda out there - I am running Audacity 2.4.2 on my M1 MBA with macOS 11.1 beta… And pretty much everything is perfect - BUT (there is always a but or I wouldn’t be here right?) The Mac now separates the headphone setting and the internal speakers into distinct choices (whereas previously speakers/headphones were one item and headphones got selected when plugged in. This is all very nice but the current build of Audacity doesn’t seem to be aware of this and so I can no longer select/use headphones as Audacity is no doubt relying on the older automatic switching… so basically heads up - can we have “external headphones” added so I can use my headphones for editing again? Pretty please - and please don’t think I am being negative or whiny - I am quite aware that this isn’t the Audacity devs fault… Apple suddenly changed from an auto switching model when the headphones are plugged in to something else.

Hi. I am not a macOS (or Catalina) user, but I know your problem all too well, as the last WIndows 10 update put me through this exact rigmarole! I ended up going to the Laptop manufacturer’s website and downloading a old driver to make things work properly, and now I am happy. :smiley: I do not think you have the same “luxury” with apple, but I do not know.

(In Windows, at least), Audacity only provides you the options the OS presents to it.

Perhaps a macOS Audacity elf will comment further…

There may be something in Audacity that I have missed but at the moment I’ve worked around it using Loopback and created a virtual output that pipes Audacity to the headphones… (although you wouldn’t want to buy Loopback just to do that - but as I already have it it’s the simplest workaround) main point of the post was just to throw the Devs a heads up… thanks for the reply though

Did you try “Transport menu > Rescan Audio Devices” (after connecting the headphones)?

Did not know that was even a thing - shows how much I know… and yes that fixed it - thank you - that means I can tell you that Audacity 2.4.2 is working perfectly (as far as I can tell atm) for all the things I do with it editing my podcast (Essential Apple Podcast in case anyone cares :wink: ) on M1 with 11.1 beta. PS: I miss the decibel view - sad that’s gone, any chance of it returning? Otherwise a very happy user of Audacity for many years now - keep up the great work people - appreciate it a lot.

I miss the decibel view

DB view is not gone, just hidden.

Control-Click the vertical scale on the left


Normally that is not necessary if the headphones are connected before launching Audacity, but if you need it, you know where it is :wink:

Thanks everyone for the replies - I suspect the headphones thing is because Apple changed how it worked - anyway now I know how to deal with that if it reoccurs and thanks for the Db tip that’s great for me… cheers for all the help