Audacity 2.4.2 not playing audio on macOS Catalina

I updated my Macbook to macOS Catalina a few months ago, and Audacity wasn’t working. No matter what I did, I could not play any audio from it; any time I would attempt to play audio, an error message would show up.

Recently, I downloaded Audacity 2.4.2 onto my Macbook, and I still can’t play any audio. The same old error message shows up.
Screen Shot 2020-07-17 at 1.07.11 AM.jpg
Is there any way to fix this? Because if not, I’ve already come to the conclusion that Audacity will never work on my Macbook ever again.

Try playing to your Macbook internal speakers instead of external headphones as a test. What kind of headphones?

Audacity will never work on my Macbook ever again.

It’s not unusual for people to roll their machine back from Catalina to Mojave or High Sierra because Catalina created so many problems.


Screen Shot 2020-07-17 at 1.35.27 AM.png
The posting I saw has over a million hits.


Please go to Apple menu > System Preferences > Sound > Output. What options do you see there? Can you switch to “Internal Speakers”?

I’ve not seen “External Headphones” as an output option. What headphones are you using and how are you connecting them?

– Bill

What headphones are you using and how are you connecting them?

Part numbers are good.

Wireless? Part of a headset combination? Both of those are special purpose and sometimes demand drivers or additional software.


My MacBook has External Headphones, MacBook Air Speakers, iShowU Capture Device, and Multi-Output Device.

I cannot see “Internal Speakers” as an output option on my MacBook. All I have is External Headphones, MacBook Air Speakers, iShowU Capture Device, and Multi-Output Device. I think I’m basically screwed at this point.

MacBook Air Speakers

I wonder if that’s not the Macbook’s internal speakers. My Macbooks’s speakers were pretty dreadful and it was a nice shock when I bought the Air and the built-in sound was so much better. No trouble watching a movie or show on the Air whereas that was a stretch on the Macbook.

Turns out the Air uses custom compression drivers instead of plain tiny speakers. It would be a significant improvement if Apple put the Air’s speakers inside the Macbook.


I feel like the MacBook Air Speakers are the internal speakers.

Also, I feel like the no sound playing issue is also happening on other software I downloaded onto my MacBook, like LMMS and SoundBridge. I’m not sure what the problem with my MackBook Air is here. The only reason I have iShowU Capture Device and Multi-Output Device there is so I can record my MacBook’s internal sound whenever I use OBS Studio, and I had to follow a tutorial video on that. I’m curious if there’s a similar method of getting sound to play in Audacity (as well as LMMS and SoundBridge, as stated before) just like the method of recording internal sound on Mac with OBS Studio.

I’m not sure what I did, but I think by changing some settings in my Multi-Output Device, I ended up getting the sound in Audacity to actually play.

I guess it was all trial and error until I somehow screw up and Audacity isn’t playing anything on my MacBook again for some reason.

I have been having the same problem for a loong time. I just haven’t tried to deal with it for a long time, either, because I couldn’t find any help. TodayI decided to try again. I’ve upgraded to version 2.4.2 of Audacity and I’ve upgraded the Mac OS to 10.15.7. I tried fooling around with the output device. I have three choices in the popdown list, the internal speakers, the external speakers, and my video monitor which is connected via HDMI, but isn’t a real choice. I tried changing the project rate, and there is only one choice for the audio host, the core audio. I tried shutting down and restarting audacity after each change. I even clicked the “reset configuration” menu under “Tools”. Nothing has fixed the problem. Is your version of Audacity still working after choosing a different output? Is there something else you did that might have fixed the problem for you, something different from what I’ve tried?



I have replied to your topic here: Stops playback while editing. Error msg. on retry