Audacity 2.4.2 - Mac OSX 10.13.6

Hello -
I am just getting started with Audacity.
I’m trying to record audio out of my guitar amplifier. It has a USB out for just this type of thing.
I’ve opened Audacity and checked that my Mac Book Pro (Laptop 2011) sees it. It does. However, I can’t get audio through it to record in Audacity.
If I switch to built in microphone, then I can see the recoding, but it’s just through the internal microphone and not through the USB input.
I checked the audio permissions in the Apple System Preference panel. It shows my Amp. So, the computer sees it. I checked the privacy and security panel after seeing a similar post. However, under the privacy tab I do not see the microphone icon in the list.

Any ideas what I am missing?
-Thank you in advance-

Have you check all the recording options in Audacity under Preferences → Devices?

I am having an associated problem. Boss Katana Amp to Audacity. Everything recognised, but input volume jumps to max even with everything turned right down.

What odododododod said.

Also, start Audacity after you plug in your USB port. Alternatively, do Transport > Rescan Audio Devices

I hope this helps. :smiley:

Audacity just records what is sent to it. The volume is generally set prior to the USB port. In this case, the volume will be set in your amp. Try turning down the volume on your guitar and/or your amp. I am sure you will find the right combination of settings.

I hope this helps. :smiley:

The Katana amp controls do not have any effect on USB output. I would be surprised if anyone would not try that first.

So you do not have a volume control on your guitar ?