Audacity 2.4.2: build failure on antix 4.9.160 32-bit [SOLVED]


I am trying to build 2.4.2 on Antix (32 bit) without success. I followed the instructions from
To recap what has been done:

  • Installed cmake 3.17.4 from the sources and then follow the above link.
    gcc is 6.3.0

The build gets stuck at this point:

[ 43%] Linking C static library ../../lib/audacity/liblibsndfile.a
[ 43%] Built target libsndfile
Scanning dependencies of target libsoxr
[ 43%] Building C object cmake-proxies/libsoxr/CMakeFiles/libsoxr.dir/__/__/lib-src/libsoxr/src/cr.c.o
cc: error: unrecognized command line option ‘-msse -mfpmath=sse’; did you mean ‘-mfpmath=sse’?
cmake-proxies/libsoxr/CMakeFiles/libsoxr.dir/build.make:82: recipe for target 'cmake-proxies/libsoxr/CMakeFiles/libsoxr.dir/__/__/lib-src/libsoxr/src/cr.c.o' failed
make[2]: *** [cmake-proxies/libsoxr/CMakeFiles/libsoxr.dir/__/__/lib-src/libsoxr/src/cr.c.o] Error 1
CMakeFiles/Makefile2:2096: recipe for target 'cmake-proxies/libsoxr/CMakeFiles/libsoxr.dir/all' failed
make[1]: *** [cmake-proxies/libsoxr/CMakeFiles/libsoxr.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2

Can you help?

Are you building on an old computer? Does it have SSE2?

Thanks for the quick answer.
I am running Antix on virtual box (win7) on a relatively new machine (~ 4-5 years old)

However, this is just for testing. I then would like to install Audacity on Antix on a pentium 4 at some point.

I know Audacity will build on Debian 10 64-bit in VirtualBox / Ubuntu host, or macOS host, and I’ve built previous version on 32-bit Debian in VB with Ubuntu host, but I’ve never tried 32-bit Antix with Windows 7 host.

Have you installed Guest Additions?

Have you installed Guest Additions

Yes, it’s installed.

In the meantime, I have installed Antix 4.9.212 (32 bit) in Vbox as before. ISO image is antiX-19.2_386-full.iso
Same issue, stop at the same step.

The image I installed first was antiX-17.4.1_386-full.iso

Is 64-bit Debian not an option?

Unfortunately not with a Pentium 4 and my motherboard. I have a couple of them I would like to repurpose for my workbench.
It could have been fun to use Audacity as a signal generator…

Is there an older version that would work in a 32 bit environment?

Do you think it’s a problem with the virtual machine because I could try to build it in the “true” OS?


Audacity 2.4.2 “should” build on 32-bit Linux, I’ve just not tried it myself.

In your Antix guest OS, what do you get if you run:

cat /proc/cpuinfo | grep sse2

cat /proc/cpuinfo | grep sse2

flags		: fpu vme de pse tsc msr mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht rdtscp constant_tsc xtopology nonstop_tsc pni pclmulqdq monitor ssse3 cx16 sse4_1 sse4_2 x2apic popcnt aes xsave avx rdrand hypervisor lahf_lm fsgsbase

That’s good. It’s reporting that you do have SSE.
Which exact version of Antix are you using? I’ll try installing it in Virtualbox and see if Audacity will build for me.

Thanks again for your help.
I have 2 iso images I am using:

antiX-17.4_386-full.iso from
antiX-19.2_386-full.iso from

I would just use the latest one.

What a horrible distro.

How did you install cmake 17?

How did you install cmake 17?

I installed it from the sources

Please be more precise. I’m trying to reproduce your setup.
The recommended way to install the latest stable version of Cmake is to download and run the cmake “.sh” file, but that’s only available for 64-bit OS, so I’m not clear how you installed Cmake.

Run: (note it’s without cmake)

sudo apt install build-essential gcc libgtk2.0-dev libasound2-dev python3-minimal libavformat-dev libjack-jackd2-dev

Go to , download cmake-3.17.4.tar.gz and unpack it.

Go to the folder that contains the file “bootstrap” and type:

./bootstrap -- -DCMAKE_USE_OPENSSL=OFF

OPENSSL is not installed by default. That’s why you have to turn this option OFF. You can as well just run ./bootstrap. After a few minutes, you should get a message telling you to add that option or install openssl. I don’t need openssl, so I didn’t install it.




sudo make install

cmake will be installed in /usr/local/share

Then continue from without reinstalling all the packages.
You will just need git.

Maybe I should modify the title of this thread because it’s not antix 4.9.160. Let me know. Thanks

I can reproduce the problem on Antix.

I’m now looking to see if this is a general problem for 32-bit Linux, or if it is specific to Antix. If it’s a general problem, then I expect that it can be fixed at our end. If it’s specific to Antix then I’d guess that it’s due to some missing dependency.

Unfortunately I’ve hit a problem setting up 32-bit Ubuntu due to a bug in VirtualBox Guest Additions. I’m currently trying to work around this problem.

I’m getting the same error with Ubuntu 18.04 32-bit.
I can see where the problem lies, but not how to fix it, so I’ve sent an enquiry to the Audacity developers. I’ll update here when I have more info.

Thanks for your help

One of the developers is looking into it and has identified the cause - He’s now looking for the best way to fix it.

We have a fix.
cmake.patch (3.27 KB)
Download the “cmake.patch” file, and put it in the root of your Audacity source code (If you’re using the official audacity-minsrc-2.4.2.tar.gz, then that will be the “audacity-minsrc-2.4.2/” folder.)

Open a terminal window and navigate to the “audacity-minsrc-2.4.2” folder.

Apply the patch:

patch -p1 < cmake.patch

Delete the contents of your build folder, and run your cmake command followed by “make”.