Audacity 2.4.1 DOESN'T WORK in Linux Mint 19.3

Hello everyone

I’ve been using Audacity to record my own podcast since 2007/2008 and never had a problem. Also, I’ve been using Linux since 2005.

I’ve never had a problem like this. I’ve using Linux Mint with Audacity for the last 3 years and I do a weekly podcast, so, go figure how many shows I’ve recorded without even a glitch.

Thing is that after my system updated to 2.4.1, I push the REC button, the arrow starts moving, but I can’t see the usual equalizer. When I push STOP, I can’t see what I’ve recorded. If then, I resize the window, my recording appears magically (see the picture attached) BUT I can’t do anything to that track, nor edit or erase it, anything.

I’ve tried installing an older version (2.2 or 2.3) but it seems that it’s not possible, neither using synaptic or downloading the .deb myself.

Any ideas? Anyone with the same problem?

Thanks guys!
Full Window000.png

How did your system do that? Audacity 2.4.1 is not yet available in the official Ubuntu / Mint repository.
Do you use a PPA for Audacity?

I… Guess? I don’t remember doing anything out of the ordinary…

The most commonly used PPA for Audacity is the “Panda Jim / ubuntuhandbook1” PPA.
The Audacity 2.4.1 build in this PPA appears to be incomplete / faulty.

In my opinion, PPAs should only be used by people that are reasonably “expert” with Linux, because PPA maintainers rarely provide end user support.

To see if you are using a PPA, you need to find out how to view your “software sources”.
I don’t use Mint, but I read that you can access software sources via:
“Menu button > Administration > Software Sources”

Thank you, I will.

And then, to use the correct ppa and the correct working version of Audacity… Just change the ppa…?


Thanks for all the help, Steve

I have this one;

deb bionic main

I attach an image too. I understand that’s not the right one…? So, how I can add the right one?

Thanks again.
Captura de pantalla de 2020-05-23 13-32-38.png


First, I installed trough synaptic the audacity-data package forcing to install and old version (2.2.1-1).

Then, I downloaded the .deb from here and I installed manually.

I got the Audacity 2.2.1 version installed that works just fine for me so… It’s solved.

Thank you a lot anyway, Steve!


Super :slight_smile:

For anyone else reading this, a slightly easier solution would have been:

  1. Uninstall audacity and audacity-data
  2. Remove the check mark from the PPA
  3. Refresh the list of available packages
  4. Install Audacity with your usual package manager (for Ubuntu / Mint, install the “deb” version rather than the SnapCraft version)

Since my updates manager was trying me to install 2.4.1, I did that and now doesn’t say I have an update. So, thanks again, buddy!