Audacity 2.4.1 Chops Off A Piece Of My Recording


I recently upgraded to Audacity 2.4.0 and subsequently to 2.4.1 and hadn’t used it since I installed it.

I’m running MacOS Mohave 10.14.6 on a 27" 5K iMac with a Behringer UCA 212 DAC.

When I tried to use Audacity today I discovered that my old Latency Compensation settings were off, so I figured out the new number and put it in the field (-1889 milliseconds). I also removed my old “audacity.cfg”, “pluginregistry.cfg” and “pluginsettings.cfg” files to reset the application to its original state. Even so my problem continues.

Whenever I record something the program chops off about the first two seconds of my recording. This is terrible. Especially when I try to punch in a segment of audio. This didn’t happen with version 2.3.3.

I tried removing the -1889 millisecond setting but that didn’t help at all. Oh, and by the way, I have other software like Twisted Wave and Garageband and neither one has this issue.

Any idea what could be going on?

Click inside the recording meters and select Start Monitoring. Do they start bouncing right away or do they wait a bit?

It’s Mojave. Apple used the Spanish version.


Are you using iCloud services or connections? Audacity doesn’t like that very much. Does it still act funny if you disconnect the network?

Either drop the WiFi connection in the top right or Apple (upper left) > System Preferences > Network > Ethernet > Configure IPv4 > OFF.

Oddly we’re looking for either it starts working, or it changes to something else. It’s good to know either one. If everything just stops dead, then you may be running much of the machine from your cloud account, and that may take care of Audacity until the next version or two.


Hi Koz:

Thank you for your prompt response.

I clicked inside the recording meters and selected ’Start Monitoring” and the meter started bouncing right away.

As for the Internet thing, I don’t use WiFi on this machine, so I turned off the Ethernet connection. That didn’t help either.

What’s weird is that the problem doesn’t happen with any other application. And it’s not something subtle either. Every time I record it cuts off about 2 seconds at the beginning, which makes the application basically useless.

I could always go back to version 2.3.3 but this must be an issue affecting many other people so I guess you would like to find the culprit.

Hi Koz:

The problem is the application!!!

I removed version 2.4.1 using AppCleaner and replaced it with version 2.3.3… The problem went away.

However, I would like to eventually go back to version 2.4.x.

Let me know when you find what’s wrong.

Thank you.

Did Appcleaner remove the audacity.cfg file? See

Perhaps this was the problem all along.

You don’t need Appcleaner to do a “clean” install of Audacity - just reset the settings as explained above.

You might try installing 2.4.1 to see what happens. Rename the “Audacity” application to “Audacity 233”, so you can have both versions available to compare. You just can’t run both at once.

– Bill

Hi Bill:

Not version 2.4.1 works fine.

I’ve always liked AppCleaner because it removes all the little pieces of digital crud that applications tend to leave behind between upgrades. And in this case it seems like I had something from a previous version messing up my new app.

What I did notice is that when I have both version 2.3.3 and 2.4.1 installed side-by-side they share the preferences. I also noticed that I can’t use four numerals in the “Latency Compensation” window. In my case -391 milliseconds is too little and -392 milliseconds is too much. I tried to fine tune it even further but it didn’t work.

Thank you for your prompt response.


You can’t hear a difference of 1 millisecond. That’s the length of time it takes sound to travel about 1 foot. If 1 millisecond mattered a classical orchestra would not work.
– Bill

Good morning Bill:

I didn’t know that. Thanks for the information.

Have a great weekend.