Audacity 2.3.3 track display area not updating on Linux

I have been using Audacity successfully on my xubuntu 20.04 laptop for quite a while, thank you developers.

I have just installed Audacity 2.3.3 on my desktop machine, also running xubuntu 20.04 and it has a very strange display problem. The track display area doesn’t get updated, symptoms as follows:-

1 - If I open an audio file I get the initial display but if I hit play the sound plays but nothing changes in the track display area, no ‘play bar’ moving across the tracks.

2 - If I move from another workspace back to the one where I have Audacity running the track display area in Audacity has a sort of ‘window’ into the previously displayed workspace

3 - When I start Audacity the splash screen isn’t shown, there’s just an outline with nothing in it.

4 - If I resize the Audacity window the track area gets updated but just once.

Other programs all work pretty normally and this isn’t an old or slow system really - I5 processor, 8GB main memory, NVME SSD disk drive, etc.

I also tried running Audacity on my laptop via an ‘ssh -X ’ from my desktop (i.e. program running on laptop, displaying on desktop screen) and that worked OK, so it doesn’t appear to be a specifically screen related problem.

Any ideas anyone what might be wrong?

I’ve just seen your reply here:
Is the issue now solved for you?

It’s solved in the sense that the workaround of unsetting GTK_IM_MODULE works OK. However it would be nice to work out what the real issue is.

There are some clues:

The problem is in the file ~/.xinputrc, which sets xim with the line ‘run_im xim’. If that file does not exist the system defaults to /etc/X11/xinit/xinputrc which contains the line ‘run_im default’. I have deleted the file ~/.xinputrc and all is good.

I have no idea who selected that setting or why. And, I’m running Mint 20/Mate.