Audacity 2.3.3 not playing nicely with Jabra Pro 930 Headset

I have Audacity 2.3.3 and have been using a Jabra Pro 930 headset for several years, using it with different computers and telephony programs ranging from Google Voice to Skype to Zoom. When I fire up Audacity to record a small reading project, it flatlines on input. The built-in mic works, and I’m using the same headset for online meetings. Audacity is the oddball that won’t work. The funny thing is it seems to occasionally work, but not reliably. Gain is maxed, and the system defaults point at the Jabra. Is there something I’m missing?

Most applications make a connection to the audio device, and retain that connection until the application is closed.
For historical reasons, Audacity does not do that. Audacity opens a connection to the audio device when required (on play or record) and then releases the device. Wireless devices are not designed to handle rapid connecting / disconnecting. That’s basically the problem with using wireless audio devices with Audacity.

Hopefully Audacity will eventually update to keeping the connection open (since all operating systems can now handle this).

Steve said it best but I wanted to add that this was my experience too. I tried Bluetooth headphones as well and it did not work with Audacity. There was a noticeable gap and drop outs. When I switched to headphones using the 3.5mm port, it worked just fine.

Thanks for the answers. It’s disappointing, given that telephony and conference tools work with the same hardware. Do the developers track this forum, or is there a feature request topic? Is this a Windows thing, or would I find the same thing in Linux? Love the product, but I’m surprised by this unexpected limitation!

One does (me).