Audacity 2.3.2 will not record audio

I am using Mac OS 10.15 Catalina. Just upgraded and lost Audacity. Just downloaded Audacity Beta (2.3.2). And… can’t record audio!!!

I’ve checked several threads regarding this same issue, but have not found a solution. I tried doing the suggested workaround by opening the app using Terminal. No luck.

I followed the FAQ instructions in the Audacity manual under the help section. It advised going into system preferences, then security and privacy, click microphone on the left-hand menu. It opens the microphone window and does not show audacity as an app to grant permission to. It’s as if my computer doesn’t recognize Audacity at all.

Any suggestions on how to get my computer to recognize Audacity so that I can grant it permission to use my microphone?

have not found a solution.

We haven’t found a good one, either.

Can you roll the machine back pre-Catalina? Did you come from Mojave?


I tried the terminal workaround again. This time using the second method (sudo). And it worked! See below.

You can open Audacity via the terminal using the following command:
open /Applications/

This will open Audacity and then Terminal will actually ask for the correct permissions. If for some reason this doesn’t work, you can try opening Audacity as root:
sudo open /Applications/

To access the terminal, go to applications, then utilities, then terminal. Cut and paste the command. It may ask for a password. After that, it works fine.

After that, it works fine.

Forever? Or next time you have to go through all that again?

Needing to run Audacity as Super User is not working fine. It’s dangerous.


What is dangerous about using it as a super user?

Superuser has “root access”.
When using an application as “root”, you are granting that application unlimited, god-like powers to modify the operating system.
Root access should be used only for making system changes.

I had to go through it again to open the app and run it. I was unable to open previously “recently used” files and had to open them using “open”. But other than that it worked fine for my purposes. I will be deleting this version of the app until the beta test is over and they have a new version that runs on Catalina.