Audacity 2.3.0 on macOS Sierra 10.12.6 - Won't Open .M4A files

I was recently using Audacity 2.1.3 with some .M4A files with no problems and decided to check and update to the latest version. For some reason, files initially wouldn’t open. After setting the extended import options to FFmpeg-compatible files at highest priority and downloading FFmpeg/LAME as a backup, the file seemed to open but lasted 2 seconds with a high pitched sound. Additionally, I had seen another post on the forum mentioning to check for a certain file in the “*/Library/Application Support/audacity/” Folder and delete it. I couldn’t find this said file.

Kinda stuck and would like to use the new version. If it doesn’t work, I guess I’ll stick with the old version.

Have you tested that .M4A file with your old version of Audacity?

Yes, the .M4A files work on the older version without issue, it’s just on this newer version they don’t for some reason.

You’re looking for ~/Library/Application Support/audacity/; note the “~”, not “*”. What file were you meant to look for?
– Bill

I had seen on a different post that potentially deleting some audacity.cfg file (may not be the right file extension) may restore .m4a compatibility. That’s why I had checked in that folder location.

Similar problem here, after updating from Audacity 2.1.1 to to 2.3.0 on a Mac with macOS 10.12.6 Sierra:

Trying to open an m4a file results in an error message saying “This version of Audacity was compiled without Quicktime support” (or so).
Let me point out, that the ffmpeg library was not present on the machine, as Audacity 2.2.1 used to be able to open m4a without it.

As suggested above, I deleted (actually: renamed) ~/Library/Application Support/audacity/ and started Audacity again: A new directory was created, but Audacity would still run into the same error, so I restored my previous configuration directory.

Assuming that support for AAC and ALAC is indeed missing, I installed the ffmeg library. As a result, m4a files (AAC as well as ALAC) can be opened now.
I have no problem with this solution, but it should be clearly documented, and I’d wish “native” m4a support being provided again with the next release. After all, AAC and ALAC files are very popular on the Mac platform.


Could this be the same bug that had happened with 2.1.0 ?
So, why were some users seemingly able to fix this by just generating a new config file? I suppose, they just fixed a broken path to the ffmpeg library, which they had installed. However, the previous version of Audacity would import m4a even without the library.

No idea what’s wrong here? No reaction?

It seemed you had solved your problem by installing the FFmpeg library so no further comments were needed.

I’ll make sure the developers are aware of the issue.

– Bill