Audacity 2.1.3 Win 10 and Focusrite Scarlett 2i2 [SOLVED]

EDIT! FIXED! See below

I’ll leave this post complete in case anyone finds it by searching…

FIX: Basically, I had misread “This driver is for use with Scarlett 2i2/Studio 1st Gen devices ONLY” as “this is the only driver you can use on 1st Gen devices”.

The focusrite helpline said I should use the new 4.36.4 drivers from the 2nd Gen page at

It required a bit of coercion to force the right driver to be picked up in device manager (“select manually, choose second one down”), but now everything works perfectly - skype, Audacity, the lot!

Original post

Audacity 2.1.3
Windows 10 x64 15063 Build 15063.483

I can’t be sure exactly when it started as I hadn’t recorded for a while, but I have a Scarlett 2i2 rev 1 interface.
I used to have it set to WASAPI and record and listen via Scarlett.

Now what happens is that when recording, unless I have the Recording and Playback devices both set to the Scarlett, I get an error:
When playing back I get the same error if the playback option is not set to either line our or speakers. The error is:

"Error opening sound device. Try changing the audio host, recording device and the project sample rate".

I’ve actually tried all of the above.

The onboard soundcard is a Realtek card on a Gigabyte Z97P mobo with driver version 6.01.7727 dated 22/01/16.
However, I’ve tried completely disabling that and there’s no difference.

I also notice now that Skype also does not hear the microphone, nor does Windows voice transcription, BUT… windows inbuilt voice recorder can record, but only picks up left channel.
Which makes sense because the 2i2 has two XLR ports and my R0DE NT1 mic is plugged into the left port.

Of course, I could use the MME or Directsound options, but they are not a “pure” audio path, and they also seem to limit my recording to either -3 or -6dB, even at full levels.
Nor does it answer the question about Skype not being able to hear the mic, even when selected.

Here’s what I’ve tried over the last day or so:

  1. Changing USB ports including trying a USB port.
  2. Updating Audacity from 2.1.2 to 2.1.3 and doing a complete prefs reset.
  3. Changing the recording channels and rate.
  4. Disabling onboard soundcard.
  5. Completely uninstalling and re-installing Scarlett 2i2 with optional driver from Focusrite.
  6. Using the Focusrite control panel to change the latency settings.
  7. Changing the default audio devices.
  8. Also tried looking for an ASIO build of Audacity as suggested, but there’s nothing out there newer than 2.0.2 (yes, I read the reasons why but PM me if you can help!)
    Googled until dizzy.

I realise that almost certainly isn’t an Audacity problem, but if anyone knows it’ll be someone here!

(I dread asking on the Microsoft forum, because I know exactly will happen: an MVP will reflect my entire question back to me, and then want to start by a complete format of my hard drive).

Thanks for posting the fix.
I’ve marked this topic as solved and locked it so that it will be easier for others to find.