Audacity 2.1.3 solo issue

I’ve just updated to version 2.1.3 from 2.1.2 and when I select one track in SOLO mode, if I want to add another SOLO track to the playback, the one that was already playing stops if I click on SOLO on another track. In other words, now you can only play just ONE track in SOLO mode, it’s an exclusive option. I’ve discovered that if you press SHIFT, you can add in SOLO mode as many tracks as you want. This is way less comfortable than before.

I think this should be reversed: if you click on SOLO with the mouse, you should be able to select as many tracks as you want, and in very special occasions where you only want to listen to one track and want the SOLO mode to be exclusive, you do it pressing SHIFT. In other words, when I use the SOLO option, 95% of the time I not only select one track, but 2 or 3. There are very little occasions when I want the solo button to be exclusive. The easiest option to do (no SHIFT required) should be the option you use the most.


We made the “Simple” Solo option default in 2.1.3 because it was less confusing for most users. You can mute the tracks you don’t want to hear to (in effect) solo multiple tracks.

If you want the old behaviour back, go to Tracks Preferences and set “Solo button” to “Multi-track”.


Wow, many, many thanks, issue fixed. Thanks GOD programmers thought about it and let us users decide what we want. Ain’t nothing like let the user decide what buttons can do, hahaha.