Audacity 2.1.2 [SOLVED]

I upgraded to windows10 last July 2015, my PC originally was windows 7-64 bit. I have never had any problems with exporting mp 3 audio files before. However, since this new version came out I record a radio program from the internet, then when I export the files to my desktop, no sound comes with the program even though it shows on the wavelength that is playing.
I removed the program and all its files with revo pro uninstaller and downloaded and installed it again using the .exe installer, but still the problem persists.
Can someone please help me!

then when I export the files to my desktop, no sound comes with the program even though it shows on the wavelength that is playing.

So, this seems like a playback problem…

Can your computer play any sounds at all?
If so, can you play other-older MP3s?

Are you hearing anything when you play-back in Audacity before exporting?
If so, try exporting to WAV and see if you an play it.

I have tried saving the audio in WAV format and MP3 and neither one plays back any sound, the only sound I hear is the one picked up by the built in microphone in the PC camera picking up the sound from the TV set which is next to my PC. I have tried a lot of different things but no sound comes out from the saved files. This was never a problem with the previous Audacity programs. Something is definitely wrong with this Audacity. Does anyone else have encountered this problem?
Please, HELP!!!
Abe Robles

Have you connected a USB device like a mic or cassette player to the computer? If so, simply unplug the USB device, then Windows will have sound.

Audacity will still not have sound until you go into Device Toolbar, fourth box (playback device), and change the device to the playback device you are trying to use. What device is that - computer speakers? Don’t mute that device or you will have no sound.

If the problem is only in Audacity, right-click over the speaker icon by the system clock, then choose “Open Volume Mixer”. Play a sound in Audacity, then the Audacity volume slider will appear in the Volume Mixer. Ensure the Audacity volume slider is turned up and not muted.

If that does not help, press the Windows key, Power section, hold SHIFT on your computer keyboard and click Shut Down. This will give you a new kernel session, in case it is a problem that your computer is depleted of resources.


I do not have connected a microphone or cassette to my PC, the only addition is a USB addition with seven additional ports.
As for the playback device you refer to, what is there is the following:
Playback Meter Preferences-Meter Style- Gradient-Meter Type DB-Orientation Automatic
As for the other speaker icon you refer to, all is there is: Mono-Stereo - Microsoft Sound Mapper- Realtek High- Realtek Digital Output, nothing close to what you suggest I look for by right clicking on either of these speakers icons.
I also followed your instructions with the "Windows key and hold shift-Shut Down, still no sound at all. The only sound I hear is coming form the TV set that is near me. I can hear the program I’m recording from the internet and see the wavelength with the right volume, but then when I export the files, no matter what format I select, nothing at all comes from the audio. Like I stated previously, I have been using Audacity for at least 4 years without any problems, this all started since I updated to this new version.
Please, please help!!!

Realtek High- Realtek Digital Output

Assuming you’ve got analog speakers connected, there’s your problem. The audio is being sent to the digital S/PDIF connection. There should be something that says “Speakers” or “Line Out”, etc.

You can also right-click the Windows speaker/volume icon, bring-up Playback Devices, and select your desired default output.

I have tried saving the audio in WAV format and MP3 and neither one plays back any sound,

OK… I was wondering if you can play sounds with other applications, such as Windows Media Player… There’s no point in worrying about Audacity if your speakers (or soundcard or drivers) are broken and your computer can’t play any sound… I was only asking about WAV to see if it was only MP3s that were giving you trouble.

Yes I can play other sounds such as my music on Windows Media Player or Media Player Classic or any other player I have installed in my PC. I can record music and videos from YouTube and there is no problem in playing them back. The only thing that I can think of is maybe Cortana is interfering with Audacity, but I disabled Cortana, turned off the microphone and then ran a test recording something from the internet, but still not a single sound!
I am completely confounded.

That could also cause a problem. It will probably take over as default Windows playback device.

The link I gave is for Audacity’s Device Tooolbar: Device Toolbar.

That is Device Toolbar.

Audacity does not have a clock. The Windows speaker icon is by the system clock in the Notification area:
system speaker.PNG
I strongly recommend you open the Volume Mixer by right-click over that speaker icon, play a sound in Audacity then ensure the Audacity volume slider is turned up and unmuted.


Cortana may take over the mic but that is probably not your problem.

You won’t solve this unless you choose the correct playback and recording devices in Audacity’s Device Toolbar.

As Doug said, you will hear nothing if you choose the Realtek Digital Output as Audacity playback device, unless you have some speakers or TV connected to that output.

We asked you what playback device you are using (computer speakers, for example). You need to find out what playback device you are actually using, according to where the sound comes from, then set the Audacity playback device to that device. Are you trying to play to that USB 7 channel device? That won’t give you multi-channel playback from Audacity, only stereo, and only if the device is configured to send stereo to the outputs you are using.

Microsoft Sound Mapper - Input is not a good choice for recording device. That will change with whatever the default Windows recording device is. If you have a stereo mix or what U hear recording device, choose that in Audacity. If you don’t have either of those, you will get better results recording YouTube like this:

  1. In Audacity, ensure Transport > Software Playthrough is OFF (not ticked, not checked).
  2. Open Device Toolbar.
  3. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  4. In the second (Recording Device) box, choose the (loopback) input for the device you are using for playback. For example, if you are using “Speakers” for listening to playback, choose “Speakers (loopback)” in this step.
  5. In the third (Recording Channels) box, choose mono or stereo.
  6. In the fourth (Playback Device) box, choose the Speakers or Headphones that you are using for listening.
  7. Start playing the audio you want to record.
  8. Press the big red Record button in Audacity.

Again the above depends on you knowing what playback device you are using. What does Windows Sound say is the default playback device? To find out, right-click over that same speaker icon by the system clock, then choose “Playback Devices”.


The problem was in the output as you suggested, it was set for Realtek high definition instead of speakers!! I’m sorry for all the problems I have caused in this matter. I am an Audacity user for at least 4 or 5 years and never, ever had any problems with it, on the contrary, it is such a beautiful program that I am using it constantly, especially when I copy a video or audio file from YouTube that the volume is too low, I immediately use Audacity to enhance (raise) the volume and erase any background noise.
Thank you again:


Seasons’ Greetings from us too. I will mark this topic as [SOLVED] and lock it. If you have more issues, please start a new topic.