audacity 2.1.2 - clipping bar not working

I am currently on OSX 10.11.6 El Capitan

After recording several vinyl albums today, i realized that the clipping bar in Audacity 2.1.2 is not working for me.

Even when i purposely turn the gain on my mixer all the way up so that its clipping badly within audacity, the red clipping bar does not light up, and does not stay on.

I use to love this clipping bar, because it allowed me to record an entire vinyl track and would give me a warning if clipping occurred within the recorded session.

I also noticed that when doing view > show clipping… it does not show the clipping either?

Any ideas what may be going on? Is this an issue currently reported with this version, or is it just me having this problem?

Any help would be greatly appreciated.

You can get that effect if the mixer, connection, or system overloads before Audacity touches the sound. The extreme example of that is connecting a mixer to the Mic-In of a laptop. The sound is massively overloading and bleeding on the floor, but no clip lights.


The sound isn’t overloading before everything is going though, its at normal around -6db, but then i slowly increase the gain to test it out, and no clipping light comes on.

After recording several records, i saw vinyl hit the top at 0dB and was wondering why it wasn’t working. Then i tested it further and I still cant get it to work. Whats the deal?

I even uninstalled the program, removed the preferences, and tried different versions, but they all seem to be acting the same way.

Any ideas?

Looks like I may have gotten it sorted out. Did the following:

  1. Clicked on desktop and then went to Go > Go to folder
  2. Typed ~\Library\ then hit enter.
  3. From there I went to Application support > Audacity > and trashed the audacity.cfg file, and re-started the program.

It now appears to be working as it should! Not sure why that didn’t work the first time though!!

Okay, so another strange issue has come up.

I got it working, that is, until I change the quality preferences from 32 bit floating, to 16bit.

As soon as I change it to 16 bit, the clipping bar no longer works.

I tested it with both 32 bit floating, and 24bit, and both appear to work with the clipping bar. However, as soon as I change the quality to 16bit, the clipping bar no longer works!! :frowning:

Any ideas why this may be happening? Possible bug in the software??

As a test, try amplifying a 16 bit track higher than 0 dB (you will need to enable the “allow clipping” option, but remember to turn it off again when you finish testing).
Does that show clipping?

So you would like me to record a track at 16bit, and then try to amplify the level past 0dB and then leave the show clipping on?

Ill give it a test and let you know what happens…

So, ran that test and did the following:

Amplification db: 2.2
New Peak Amplitude 2.1995

Allow clipping box selected

Settings Used in Amplification:

Clipping shown after increasing amplitude:

Picture recording live (clipping and no clipping bar showing):

After doing this, it showed parts of the track that clipped. However, I’m not sure what this really has to do with what I was doing before.

Previously, I was unable to get the clipping bar to show red while recording the track in 16bit mode. See the 3rd picture.

Let me know what you think.

The clipping indicator is certainly working, as demonstrated by the experiment.

Clipping can occur below +/- 1.0 in the Audacity track. Clipping will only show up in Audacity when sample values reach or exceed +/- 1.0, but clipping may occur before the signal reaches Audacity. If the A/D converted is working at 16-bit, which it probably is, then the absolute maximum signal level out from the A/D converter is +/- 1.0. If that signal is scaled down, even by a tiny amount, then the signal that Audacity receives will never reach the clipping threshold of +/- 1.0.

Also see - the Meter Toolbar clipping indicator only comes on for four or more consecutive clipped samples.


Honestly, I’m not sure I’m understanding what you are saying.

I will tell you this though. It is NOT working when recording in 16bit mode. I have had to continue recording at 24bit mode, as this allows the clipping bar, and ‘show clipping’ to work as it should.

So yeah, its not working. I’m not sure what your test was trying to prove, but, to me it seemed like a totally unrelated test.

Still looking for some help on this. Or maybe someone else can test it out. Not sure what the deal is, but its definitely not working as it should.

If we are talking about the Meter Toolbar clipping indicator, as previously stated, it requires a run of four or more consecutive clipped samples (irrespective of bit depth). Otherwise it does not light up. Show Clipping only needs one sample to be clipped.

It is good to record in 32-bit float if you have a lot of filters to apply to the recording and if you have the disk space and it does not cause dropouts.

Are you saying that when you record in 16-bit quality with input level in Audacity high enough to exceed 0 dB in numerous places, so that after recording, Effect > Amplify… shows a negative Amplification (dB) level, playing that track does not cause the Meter Toolbar clipping indicator to come on?


The issue is that the indicator does not turn on EVER while in 16bit record mode. Only 24bit, and 32bit. The ‘show clipping’ bar does not show either.

I am recording records into audacity live, and while in 16bit mode, the ‘show clipping’ nor the clipping bar work.

Even if the volume coming in from the mixer is past 0dB.

So the level coming in IS loud enough, the clipping indicators just do not work in 16bit mode!! Only 24bit and 32bit record settings.

Thank you.

But you agree they work when playing 16-bit audio that is over 0 dB?

Presumably no-one else on Mac has this problem or they would have spoken. I have not tried it.

It makes no difference what the mixer volume says. It is the amplitude the waveform is recorded at that affects the Audacity meters.


Just tested. Mavericks, Audacity 2.1.2…

For me, the waveform clipping indicator works with 16 bit audio from the internal audio. And it also works with 24 bit. Didn’t test with 32 bit, as there is no real 32 bit input and this setting is useless.

So I figured that I needed to set the project internal bit-depth to 16 bit, but still, clipping shows in the meters and in the waveform. I never change this, as I don’t see the use. A DAW should always work at its highest internal settings, imho.

I don’t know what the “clipping bar” is, really, as I usually set levels outside of Audacity and never get clipping into Audacity. The manual doesn’t seem to know either…

Is this just the red line at the end of the level meter?

FWIW: I also never set bit-depth to 32 bits and normally it is set in the application that comes with my interface. Core audio then follows these settings. No need to change it in any audio app I ever encountered.

Of course, I’m not on El Capitan, so it could be related to that…


Thx, Gale. That’s what I suspected, but the word “clipping bar” isn’t used in the manual…

It says clipping warning - red bar. I changed the word “warning” to “indicator” for the next Manual.



By clipping bar, I mean the little red box that lights up at the end of the meter when you clip 4 times in a row.

However, the red lines do not show clipping either when the ‘default sample format’ is set to 16bit. Only 24 and 32.

I am using this for recording records, and while there is no clipping on my mixer, if the ‘booth level’ on my mixer is turned up too much, I want to be able to see clipping in audacity so that I can stop the recording, re-adjust, and re-record with no clipping. This does not work in 16bit mode. Only 24 and 32.

Video of clipping not working with 16 bit:

Anyone check out the vid i posted above yet? Shows the issue quite clearly…