Audacity 2.1.1 recording problems on OS X Yosemite 10.10.4

Using a Blue Yeti microphone for input (it’s great), I recorded a one hour interview using Audacity on my Macbook Air, which is running OS X Yosemite 10.10.4. Unfortunately, the recording constantly skipped. Has anyone else experienced this problem on Yosemite? If so, what have you done to fix it (if anything)? Thank you.

It’s Audacity 2.1.1 (I think .dmg) and OS X Yosemite 10.10.4

As per similar posts in this Mac board.

Set up Yeti as default device in /Applications/Audio MIDI Setup with the same sample rate and number of channels that you are recording with in Audacity.

Experiment with “Audio to buffer” in the “Recording” section of Audacity Preferences. You may have to reduce it or increase it.

Turn off Wi-Fi and all other apps you can.

Right-click or CTRL-click > Get Info. Put a tick (checkmark) in “Prevent App Nap”.

Let us know which if any helps.


jsichel I have had the problem a couple of times as well as the audio meters bouncing while recording and go back to a track that is of the correct length and file size but is silent. Starting to think about buying a new program.

Version 2.11 on Yosemite 10.10.4

If you really have “2.11” it’s a bogus version. See the pink panel at the top of this page.

If you do have the skipping problem, have you tried the suggestions at Audacity 2.1.1 recording problems on OS X Yosemite 10.10.4 - #3 by Gale_Andrews


I’m suspecting an OSX problem.

And as there recently have been updates to 10.10.5, I’d try those. If they don’t show up in the appstore, get them from here:

Sorry, 2.1.1. Typo.

Do you suggest reducing or increasing the buffer? This only happens every so often, so it’s had to just adjust and excitement.

If I turn wifi off can I plug in? It’s really not much of an option for me as I need the Internet while recording the podcast?

And just for clarification, not using a usb mic. Audio is coming through a mixer into the line in port.


If you have skipping you would normally increase the buffer but it does not necessarily work like that on modern OS X. If you increase the buffer you can get serious clicking. I would try 10 ms bufffer. If recording does not start or is clearly broken up, increase the buffer in 10 ms increments until it isn’t broken up. Then use that lowest value that does not break up.

OK, try “Prevent App Nap”.

And you could try the OS X update Cyrano suggested.

OK, I would still suggest experimenting with the above.