Audacity 2.1.1 and OS X 10.10.4

I just updated to Audacity version 2.1.1 on two computers running OS X 10.10.4, and it works on one, but on the other, it won’t even open. What further information do you need in order to get to the root of the problem?

Hardware INFO? One is a 13" MacBook Pro and the other is a 2012 Mac Mini?


Are you sure it did not open? Could it be that Audacity crashed immediately after opening, before any window became visible? Just like in this case:

I don’t think it opens at all; when I click on it, the dock icon jumps up and down a few times (if I’m lucky) and then just stops. The black dot never appears underneath it. This is all happening on a 20-inch iMac with a 2 GHz Intel Core 2 Duo processor from mid-2007.

What Audacity version did you update from?

Force Quit Audacity in Activity Monitor if necessary.

Open Finder, choose Go > Go to Folder and type:

~/Library/Application Support/audacity/

In that “audacity” folder, copy the “audacity.cfg” file to somewhere else such as your Desktop.

Then delete the audacity.cfg in ~/Library/Application Support/audacity/.

If you added new plugins the last time you ran the old Audacity version, delete the entire “audacity” folder in ~/Library/Application Support/.

Try launching 2.1.1 again.

Please attach the old audacity.cfg you made a copy of, in case we can see a problem in it. Please see here for how to attach files:


Taking the audacity.cfg file, which is attached as ‘audacity.txt’, out of the Application Support folder seems to have solved the problem. Will I run into any other problems now because I did that?

I updated from Audacity 2.1.0.
audacity.txt (4.92 KB)

Thank you for the attached file.

In fact that .cfg file was last saved by Audacity 2.0.6 and has entries for obsolete preferences that go back to Audacity 1.3.x (autosave interval) and 2.0.0 (cached audio data).

And you were using a non-standard path for the Audacity temp folder.

So it is probably good to start with factory default settings. You may have to relocate FFmpeg. There should not be any other problem. If there are any more problems please let us know.


Renaming the .cfg file and keeping it in the same folder seems not to work but moving it to another folder as suggested seems to do the trick. As this seems to be a general problem with the current OS, it looks like the instruction to move the file should be included in the installation instuctions (alternatively an installer script should do the job but obviously that makes everything more complicated. Or of course an update can be produced that will fix the problem.

I have read all of the above information and I still cannot get the latest version of Audacity to open.
I have deleted all previous versions of Audacity, including the application support library, and it still will not start up.
I looked in the application support library and could not see a file with .cfg anywhere.
I have a Mid 2007 iMac running Yosemite 10.10.4.
I was running the previous version of audacity with no problems whatsoever.
Any advice?

@ RobNY: There are two application support libraries for Audacity. The one that has the .cfg file is the one that you get to starting from your home directory (~/Library/Application Support/audacity).

The move was only so that we could request the problematic audacity.cfg file.

There is no need to move the file, just delete audacity.cfg if you don’t mind losing your custom settings.

I don’t think everyone has this problem. Did your previous audacity.cfg have lines like:

TempDir=/tmp/audacity1.2-<your user name>

If so, the TempDir=/tmp/audacity1.2- line is the issue. You can just delete that line in the .cfg file and retain your other settings.

I added a mention of this to the “Mac OS X” yellow box at the top of We will look into it of course.


@Gale Andrews Thank you. Sorry for the somewhat delayed response, but I found that I didn’t have to relocate FFmpeg at all.

Thanks for your reply.
At the risk of looking really stupid, I simply cannot find a file with .cfg on it, anywhere on my machine - no matter where I look.
I can only find one folder for application support wrt Audacity and that is full of files that end .dylib
If I delete all traces of the previous Audacity, then install the latest version, from scratch so to speak, then there should be no clashes with old files anyway, is that not the case?
As I said previously, never had a single problem getting any version of Audacity to work, and that is right back from the beginning. Really strange.

If you don’t find ~/Library/Application Support/audacity/ you won’t be deleting all traces of Audacity.

All you need to do is open Finder, use Go > Go to Folder and type:

~/Library/Application Support/audacity/

Just delete that “audacity” folder.

You won’t see file name extensions unless you unhide them


Thanks for your reply, Gale.
Well, I deleted the whole folder, and Audacity still wouldn’t start.
So, I deleted audacity and all related files, again, Reinstalled it, made hidden files visible, and I still cant see a .cfg file, even when I search the whole computer.
And, Audacity still crashes each time I try to start it.
Truly, I cannot understand what I am not doing right here.

Ok, my apologies, I was foolish and could not find that file.
I have now found it, removed it from the folder, and Audacity works fine for me.
Thank you for your efforts in helping me; the error was all mine.

Thank you for this tip. I had the same problem (Audacity 2.1.1 would not launch in OS 10.10.4). Removing the audacity.cfg document fixed the problem. Here’s the old audacity.cfg (changed to .txt)
audacity.txt (4.56 KB)

Thank you for the file. I think the problem is the line pointing to the old Audacity 1.2 temp directory:


Deleting that TempDir line for 1.2 would probably fix other cases, without having to remove all the preferences.


I can’t say what causes the problem, but there is an easy “fix” that works for me on Yosemite and El Capitan when I upgraded from 2.1.0. I used this method because I wanted to keep my old settings since I had things setup how I like them, but the other option is just to delete the original folder and let 2.1.1 create its own new one and resetup everything. Would get rid of any old stuff in the folder which might be a good thing.

Go to /Library/Application Support/
Rename the audacity directory(folder) to anything you want.
Start 2.1.1
Exit 2.1.1
Rename the new “audacity” folder to something else.
Rename the original “audacity” folder to audacity.
2.1.1 should start now with the 2.1.0 settings.


This thread is a little stale, but for what it’s worth, I encountered the same problem and found a pretty simple solution. (Actually, I’m on OS X 10.10.5, but I think this will work for earlier versions.)

  • Quit all running copies of Audacity.
    Remove the Audacity folder from Applications
    Go to ~/Library/Application Support (start Terminal; type “cd ~/Library/Application\ Support”)
    Remove the “audacity” directory (in Terminal, type “/bin/rm -rf audacity”)
    Reinstall Audacity from the .dmg

Following this, Audacity 2.1.1 started uneventfully.

As implied by some of the earlier comments, the problem must be due to some old configuration files left behind by earlier versions.