Audacity 2.02,ION ITT USB turntable and WIndows 7

I’m using Audacity 2.02, Windows 7 64 bit, an ION ITTUSB Turntable.

Everything used to work great on my old computer that used Windows XP, but when my old computer broke I had to get a computer with Windows 7. The problem is this. When I go to recored an LP the sound is very distorted no matter what the sound levels. Also the bars showing the sound are almost universally a solid instead of the valleys and mountains you would normally get.

When Windows detects the USB CODEC it detects a USB Audio CODEC, but when I go to select the recording device using audacity it only lists Microphone (USB Audio Codec). Is the problems i’m having because audacity thinks the USB turntable is a microphone? Is there something I can do to correct this using my current setup?

Go into the Windows Sound Control Panel and turn down the recording level for the USB device really low.

Windows regards most USB recording devices as “microphones” if they are not a standalone sound card.

Also look under the base of the turntable, it may have a gain knob that will make the audio it sends to the computer quieter.



I am also using Win 7 and Audacity 2.02.

I found the exact same problem and a couple of others that kind of annoyed me, too, LOL! I have been looking around the web for a solution and I have discovered that people with all different kinds of turntables are reporting the exact same problems on Windows 7. It looks like the default USB audio Codec in Win7 is the culprit, not Audacity and not your turntable. Until someone creates a codec specifically for USB turntables, we will have to use the one that Windows 7 supplies, which is essentially a microphone codec. Windows 7 apparently classifies all USB input audio-devices as microphones (?!?) .

Here are the problems I have noticed:

  • The input volume is too loud (since windows thinks it’s a microphone, so it is boosting the signal, which is standard practice for mics)
  • The recording is in mono (again: why would you need stereo on a microphone?)
  • The highest possible recording setting is 16bit/48000 Hz ( and this is only after you adjust the default settings)

I managed to get the USB audio to record at decent levels by following some advice I found on another site, but so far I have not been able to find a way to record my vinyl in high quality files like I did on Windows XP (on XP I recorded all my vinyl a 24bit/96000 Hz).

To at least be able to record something properly, here are the steps in a nutshell:

(1) Go to START → Control Panel —> HARDWARE AND SOUND —> SOUND

(2) The “sound” window will popup and should have the following tabs: playback // recording // sounds // communications
Go to the RECORDING tab and find the item listed as USB audio CODEC. It will likely be listed as a Microphone, and it will likely be one of the last items in the list. Select this item and then select PROPERTIES.
(PS: selecting configure only allows you to configure the item as a microphone, so don’t waste your time).

(3) The “properties” window will popup and should have the following tabs: General // Listen // Levels // Advanced
(3a) In the General tab, you can change the name from Microphone to Turntable is you like, though it affects nothing but your peace of mind.

(3b) Go to the LEVELS tab and use the slide control to bring the input level down to 1, 2, or 3. I wouldn’t recommend anything higher as that will cause clipping in some recordings.

(3c) Go to the advanced tab and from the pull down menu select your desired default recording format. The system default is a mono (1 channel) input selection. My personal preference would be the very last choice: 2 channel, 16Bit, 48000Hz. If you are recording from vinyl, why limit it to the same lousy frequency range as a CD? FLAC and MP3 files can both be made with the 48KHz, and these files will be playable as normal in your devices of choice, so why limit the frequency if you don’t have to?
** If you do decide to go with 48000 Hz, don’t forget to adjust your Audacity default Project Rate to be 48 HZ.
This can be done by opening Audacity and going to EDIT → PROPERTIES. Choose QUALITY. Under “default Sample Rate” choose 48000 Hz. All your projects will now be recorded at this sample rate by default. **

Hope that helped…

Now if anyone can figure out a way for me to be able to record at 96KHz again, I would be very happy…otherwise I’ll need to reinstall blasted windows XP.