Audacity 2.0.6 not installing on Mac OS 10.10.2 [SOLVED]

Help please!

I can’t get the newest Audacity download to install on my new iMac with the latest Yosemite update. Any fixes or workarounds?

The screen freezes with the little color wheel freezing and this message: “Audacity could not find a place to store temporary files. Please enter an appropriate directory in the preferences dialog.”

I can’t get any farther than that because Audacity won’t install and is listed as “Not Responding” in the Force Quit app.
Audacity pic.jpg

Are you an administrator on your machine?
Apple (upper left) > System Preferences > Users and Groups > You: [X] allow user to administer this computer.

It wouldn’t surprise me if Apple tightened up system access after that security kerfuffle a while back.


2.0.6 does not officially support Yosemite. The next 2.1.0 release out soon should do so.

Make sure you are following Installation: Do NOT run Audacity from the DMG!!!.

Also try this solution to tell Audacity where to place its temporary folder by specifying it in the audacity.cfg settings file:


I am an Admin.

I have been opening the DMG. Then taking the Audacity folder on the DMG and copying it into my Applications folder. Then when I try to install I have problems.

On my other desktop, Audacity 1.3.12-beta works just fine with Yosemite OS 10.10.2 . . .

If the copy works, at that point you have installed Audacity.

How are you executing Audacity, exactly?

Did you try Audacity can't open [SOLVED] - #3 by Gale_Andrews That is likely to be the easiest way to solve the problem.

Assuming you have not already changed the Audacity temp folder, the error suggests that you can’t access /var/folders/. Unfortunately, Audacity crashes or freezes if it can’t access the temp folder it expects. So another solution would be to check you have access to that folder. At its simplest you can do that by right-click or control-click over var/folders/ then Get Info. Click the lock symbol and give your password to make changes.


I changed the cfg to NewPresInitialzed=1

The same freezing problem happens with the same error message . . . AND the cfg changes automatically to this . . .


I have all the proper user permissions, read and write . . .

Did Disk Utility confirm that and that the disk was in good order?

Please try force quitting Audacity and writing the location of the Audacity temp folder directly into audacity.cfg by deleting all its text again then pasting this at the top of the file:

TempDir=/Users/<your user name>/audacity_temp/

So if you user name was “iuchard”, put this text there:



That worked! Thank you so much.