Audacity 2.0.5 won't launch

I have just installed the latest update, and when I try to launch audacity, I get an error message “Audacity could not find a place to store temporary files. Please enter an appropriate directory in the preferences dialog” with an okay button. The okay button does not respond, I have waited up to 10 minutes. The icon in the doc shows the application is responding. I can’t get into the program to change the preference. yesterday it worked just fine.

Any ideas on who to fix the problem? I have tried deleting the plist and the .cfg and nothing works.



nothing works.

Did you restart the machine?

Yes that was the first thing I tried. After deleting the app with App Zap, and reinstalling. Still the same message.

That can be a permissions issue. Do you have “normal” drives on your machine? You’re not trying to run Audacity over a Network or anything like that? Any USB drives?

Go > Utilities > Disk Utilities
Select your system drive and Verify Disk and then Repair Permissions. Leave time. If you haven’t done this in a while it could crank and fill up the page with corrections.

Audacity > Preferences > Directories.

Mine looks like the attached. What does yours look like?

Screen Shot 2014-07-22 at 9.18.40 PM.png

I have firewire, usb and thunderbolt drives. Just repaired permissions last week.

I can’t get into Audacity that is the issue. I can’t open it, when I launch it I get the temporary files error message and it hangs. So I can never get to the audacity/preferences menu.

If you deleted audacity.cfg and that didn’t help, instead try resetting the preferences. To do that:

  • open audacity.cfg in TextEdit
  • delete everything except the line “NewPrefsInitialized=1”
  • save the file
  • start Audacity

This should force Audacity to find/create a new temporary directory inside /var/folders/

– Bill