Audacity 2.0.5 installation problem on XP

When I download and try to install Audacity 2.0.5 on my PC, I can choose to reset preferences or not…I can install in its own new folder…I try both the full and the zip files…but I get pretty much the same results. :frowning:
When I choose to reset preferences, I get the error window : “Audacity, The free, cross-platform sound editor has encountered a problem and needs to close” followed by the Audacity earphones icon. When I do not choose to reset the preferences, I get a splash on the monitor showing “Audacity” (same thing I get when 2.0 is starting up) for a second, then nothing. I do a control-Alt-Delete and see that nothing is running for Audacity. I was using Audacity 2.0 for years with no problems. If I go back to Audacity 2.0, it works. I saw a message about 2.0.4 talking about a new security progam possibly being a problem, so I turned it off and re-installed with no luck. Help!
The security program I am temporarily using is AVAST. I have windows XP Home Edition SP 3.

Did you download: “Audacity 2.0.5 installer (.exe file, 21.2 MB, including help files) for Windows 2000/XP/Vista/Windows 7/Windows 8” from ?
If not, or if you are not certain, delete your current 2.0.5 version and download it fresh from that web page (I have experienced a similar problem with the “2.0.5 alpha” version on Win XP SP3 but no problem with the official release version, so let’s be sure that you have the official release version :wink:)

I used the control panel and uninstalled the program, turned off my virus checker, and copied and pasted the web address to make sure I was on the site in your message. I chose the installer (.exe) at the top of that page for 2.0.5. I chose to run the install, add the desktop icon, and reset preferences. It did the load thing showing progress, showed the one time reset screen, and then displayed the error message I have described in my first message. This is the site and place where I had been trying to get this to work from using both the .exe and the .zip files (uninstalling between each trial.) I have also gone to the audio SB 24 bit driver and updated it to 6/13 version Thank you for trying to help me. Still not working.

I just tried to install 2.0.4 (in its own folder) and got the same results. :cry:

Please be aware of Windows XP support has ended - Microsoft Windows . This makes it very important you disconnect the internet before turning off your virus checker.

Did you ever launch Audacity with Avast! totally switched off? Avast! is a possible cause but it may have multiple processes that you must ensure are not running.

I am not sure if you ever see the Install VST Effects Dialogue when you launch Audacity but I suggest making sure Audacity is quit in Task Manager, then open

C:Documents and Settings<your user name>Application DataAudacity

If you don’t see the Application Data folder, follow the steps at to show hidden files and folders. In the “Audacity” folder inside Application Data, delete the file “audacity.cfg” if it exists, then paste in the attached file renamed to “audacity.cfg” (without quotes). This will reset preferences but also disable Audacity scanning for VST effects.

If that does not help, what language do you have “Format” set to in “Region and Language” in the Windows Control Panel?

Assuming your reference to “SB” means Creative SoundBlaster, that could be the problem. If it’s a USB SoundBlaster, disconnect it and see if Audacity launches. If the SoundBlaster is installed into the PCI slot, or if you remove the USB SoundBlaster and Audacity still doesn’t launch, try starting the computer in safe mode . This will mean only essential Windows drivers will load. You won’t have any sound devices, but it tells us the problem is not Windows.

audacity.txt (59 Bytes)

Yes! All I had to do was delete the audacity.cfg file, move your audacity.txt file in that folder, rename it to .cfg, and start the audacity2.0.5 that I had already downloaded and tried to start before. Before this fix, I got the error immediately after okaying the one time notice window of setting the preferences. I did not see the plug-ins screen at all. After I closed the error window, I clicked on the icon and the Audacity splash appeared in the middle of the screen for a partial second and then nothing.
After applying the above fix, the Audacity splash screen came up in the middle of the screen saying “Audacity” (with the earphones), and stayed this time. Then a window came up asking me to select plug-ins: [x] hard_limiter_1413. [x] sc4_1882, or just press [enter] to select both. I clicked on OK and Presto! The familiar Audacity welcome window came up. Yeah!
I was trying to update this knowing the Microsoft support was going away.
Thank you so much :smiley: :laughing: :wink: :exclamation:

You’re welcome, but I don’t really understand what is going on here.

The audacity.cfg file I attached should explicitly not scan for VST effects then load the dialogue for “Install VST Effects” (the two DLL’s you saw in that dialogue are actually not VST’s but shipped with Audacity). I just tested (on Windows 8.1) that VST’s are not scanned for, using that .cfg.

The audacity.cfg created when you launch Audacity then click “Yes” to reset Preferences should scan for VST’s, but it appears Audacity never got that far and was crashing immediately after creating audacity.cfg. Yet it seems that VST effects or other DLL’s found during the scan were not causing the crash because (somehow) Audacity is now scanning without a crash.

Audacity will probe for your sound devices and temporary directory and write these to .cfg before the VST scan. So it might seem that something to do with your devices or temporary directory was the problem, but that doesn’t explain why not doing the VST scan would make a difference.

If you do reinstall Audacity on XP at some future point, enable Reset Preferences but receive a crash (or if Audacity crashes under any other cicrumstance), please could you copy the audacity.cfg left behind after the crash and attach it (before replacing it with the .cfg file attached here). Please see here for how to attach files: .



I deleted the new audacity.cfg file and it recreated another on its own the next time I started Audacity. Then I uninstalled Audacity on my system, deleted the audacity.cfg file and reinstalled the win-2.0.5.exe file. I selected reset preferences and it went to that same window I described in my last message, I clicked on OK and Audacity came up. I noticed that it created a new audacity.cfg file. I renamed the audacity.cfg to audacity.cfg.hold, restored my ORIGINAL audacity.cfg from the trash (audacity.cfg 4 KB CFG 1/18/2013 3:01 PM), ran the install program selecting to reset preferences and got my original error after it showed me the window: “Reset Audacity Preferences … Reset Preferences? … This is a one time question, after an ‘install’ where you asked to have Preferences reset.” [Yes] [No] . I clicked on the yes button and got the original error window saying there was an error and it has to shut down Audacity. I don’t see any other window. Next, I checked the audacity.cfg file and it is still the 2013 file. I will attach it below. This is the one that was working with the audacity I had installed before I tried to update to 2.0.5. In all of this playing around, I have never seen the VST set preferences window.
I have left AVAST up thru all the above and it doesn’t seem to matter.
audacity.txt (3.86 KB)