Aud2.0 on Vista - "Noise Removal" freezing up/acting weird!

When applying noise reduction of 15dB or more it takes up to two minutes to remove noise from a 30 second recording! It turns that recording into 5secons of a high-pitched squeal that nearly blew my speakers. Applying 10 or 12db of Noise Removal seems to work OK. Just a heads up!

I’m unable to reproduce your results.
What do I need to do to reproduce this problem?

Just use it normally. Import a scratchy/hissy recording with gaps you can hear the hisssss. Get noise profile, then use noise removal at a setting of 15dB. I uninstalled and re-installed audacity, problem has gone away.

I tried that and Noise Removal behaved as expected.
I’m surprised that reinstalling made any difference unless you also reset the Audacity Preferences.
If this happened on just one recording it’s possible that there was corrupt data in the recording that caused the problem.

October 2012 Update on this issue:

After having removed and reinstalled Audacity several times since this post, Noise removal still exhibiting the same behavior - with different projects, not just the same file.

I may be the only person using Audacity that this has happened to, but we have an old expression in America that goes something like, “first time for everything”.

Let’s put our heads together and try to diagnose what’s going on.


As I wrote before, I would be very surprised if reinstalling fixed anything.
Have you tried resetting the Audacity preferences? Doing so returns Audacity to the user default settings, so it is far more useful than just reinstalling.
If you are using the current Audacity 2.0.2 installer there is an option to reset preferences. Audacity 2.0.2 is available here:

We can’t take this anywhere unless you post an example file (at or or similar), tell us exactly the time range of the selection you chose for the noise profile (look in “Selection Start” and “End” in the toolbar at the bottom), and tell us exactly all the values for all four sliders in noise removal that then demonstrate the problem.

To know how to use Noise Removal please see: .


I have attempted to reset preferences via the instructions in the online manual. “Open audacity.cfg” in a word processor such as Word Pad". First of all I cannot find “audacity.cfg” anywhere on my PC.

Please provide alternate instructions for me to reset preferences in Audacity , thanks.

Please “read” my last post.

Alright, I figured out how to do that. I’m an audio guy steve, not a computer person. The worst thing to happen to audio is computers! lol

And I figured out what I was doing wrong with Noise Removal and it was so stupid: Out of instinct I was typing “-15”(as in MINUS) in the noise reduction level field, instead of just 15. Thus I was inadvertantly raising the noise level instead of reducing it. So I am definitely not a numbers person either.

But thanks for your patience.

Never mind, it could be worse, you could be a musician (like me :smiley:)

And the funny thing is Steve: I was not even aware of putting the “-” in front of my value. Now I can start using some “real” noise removal values, like 20 or 30dB! :slight_smile:

Thanks for letting us know. Hmm, even entering “-1” gives garbage clipped audio, never mind the background noise is increased. Shouldn’t we prevent entry of minus figures or treat them as zero?

Do you still need to post a file as you asked by PM? MP3’s can be attached in the Forum if they are smaller than 1 MB.

If using Sendspace, you do not need my e-mail address, leave the recipient at “” but post the address of the download here (the address is given to you when your upload completes).


It’s OK now Gale. As stated I figured out what I was doing wrong. Making that field a “numbers only” sounds like a good idea Gale. The mp3 I attempted to attach was only 25sec long at 128kbps, but I got a message that “mp3 format uploads are not allowed”. ???

The only thing I can think is that there was something “odd” about the file - perhaps you omitted the file extension by mistake, or there was some conflict between the extension and the detected content type.


@TheKMan: I’ve split your unrelated question about MP3 extensions to .

I’ve split your unrelated question about Plot Spectrum settings not “sticking” to .

Please continue the discussions there.