.aud file bloat

I’m using 2.4.1.

I notice my .aud file is very large (around 560 Mbytes)

Looking inside the file (it’s plain ole XML, it seems) I see there are vast numbers of elements.

Since all the snipping and joining has been completed there are only about 4 Tracks in play. I am guessing all those elements
are a residue of my snipping and joining. Does joining two clips do all the clean up a naive user (me) would expect? If not, is there a way of purging all any unneeded elements?

(I am getting problems stashing my project into a CVS repository, by the way.)

Do you mean “.aup” file?
If so, that seems extraordinarily large. Are you certain that it 560 MB? How long are the tracks?
If not, what do you mean?

Yes “aud” tripped wrongly off the fingers. Sorry about that.

The project will contain about 6 tracks when complete. The duration is the usual 3’30"-ish.

The aup is usually quite small - a few 10s of Kbytes. The “bloated” version appears after I have done lots of Edit >Clip Boundaries >Split and

Join operations, and lots of Delete operations. I haven’t tried to count the number of these ops and compared it to the number of elements, I’m afraid.

I imagine there is an in-memory tree that gets marshaled out to file during a Save. And somewhere in the lifetime of a project, there must be a “pruning” process to remove tree-stuff that has become redundant because it’s cancelled out by other stuff. It looks to me like the “pruning” is sometimes not done before a Save.

I am going along OK now, just checking the size of aups before I attempt to commit them to CVS. I haven’t worked out what make Audacity prune the aup down. So it is trial-and-error.

But I can probably find a “bloated” copy if that would help.

I’d be interested to see that if you can find one and upload it somewhere.

I have (I think) put a “cloud” copy at this link: https://drive.google.com/file/d/1eg86SnXyKHtp77Hpww7UVoTIX2lYxide/view?usp=sharing
(I’m struggling a bit, trying to do this working with my longest-handled spoon 8^) Let me know if this doesn’t work for you.

Thanks, got it.
Those “control points” are “envelope control points” (https://manual.audacityteam.org/man/envelope_tool.html)
You have millions of them (8,388,610 to be precise), and they are all completely redundant (they all have the value “1.0”). There’s certainly far too many of them to have been created in the normal way (with the “Envelope Tool”), so the obvious question is, how did you create them?

If you can open the project in Audacity, and then “Save Project As” to give the project a new name (save to a normal hard drive), then Audacity may be able to sort out the mess.

By the way, are you aware of this: https://forum.audacityteam.org/t/ubuntu-mint-audacity-2-4-1-ppa-problem/57517/1