Attempt to initialize effect failed

I am using Audacity version 2.4.2 Windows 7. I have had 0 issues with this other than the export loss of audio glitch. Tonight I opened preferences to arrange the plugins by type instead of alphabetical order. As soon as I made the change I got the message in the subject line. "Attempt to initialize effect failed. There’s a couple of effects that keep popping this message up over and over. Hard limiter and Gverb. I can’t get to any settings or diagnostics. I even tried a hard reboot. Any suggestions? Hasn’t been my week. My board took a crap on Monday. I may auction a kidney to cover that. Hopefully this is a quick fix. I could always uninstall/install. But I hate to.

Hard limiter and Gverb are no longer included in Audacity.

“Hard Limiter” has been replaced by a much better “Limiter”
“Gverb” has been replaced by a much better “Reverb”

I never used either. They were included in a earlier version. But this dosen’t resolve my issue. The message pops up when I try to launch the program. I guess I am going to uninstall install the program. Not a fan of that. I even went to the plugin file location to disable the 2 plugins. Neither were listed. So I’m not sure what the glitch is.

I think the problem is primarily due to updating from a very old version (GVerb was removed several years ago).

I’d suggest that you try resetting Audacity.
To do that, you need to shut down Audacity, then open (in the Windows File Manager) the hidden folder:

C:\Users\<your user name>\Application Data\audacity\

and delete the three files:

  • audacity.cfg
  • pluginregistry.cfg
  • pluginsettings.cfg

When you restart Audacity you should see the “Welcome” screen.

This worked for me!
(I suspect it worked for others as there are no “still happening” follow ups)
One thing though, I had to type in the path explicitly …
"C:\Users\Jehosaphat\Application Data\audacity"
… to arrive at the folder.